Opened 7 years ago

Closed 7 years ago

Last modified 12 months ago

#6069 closed defect (duplicate)

SCUMM: accented characters not displayed in msg boxes

Reported by: misterhands Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

Not sure if this is a SCUMM engine or GUI issue.
This occurs in various SCUMM games, French DOS version, floppy or CD.
I use the latest daily build of SCUMMVM, win 32.

Accented characters are not displayed in messages boxes,
such as the pause message, or the F8 key Are_you_sure you_want_to_restart type message.
Example:
the pause message in MI1 is : "Jeu arrêté. Appuyez sur SPACE pour continuer."
SCUMMVM displays : "Jeu arrt. Appuyez sur SPACE pour continuer."

The strings are correct in the resource files and are displayed correctly in DOSBox.
This problem has been there forever in SCUMMVM, so this is not a regression.

Ticket imported from: #3538742. Ticket imported from: bugs/6069.

Change History (4)

comment:1 by lordhoto, 7 years ago

The problem here is that the original data files use some DOS charpage in the case of DOS versions (and maybe others for Amiga, Mac etc. versions), while our GUI fonts are either ISO-8859-1, ISO-8859-2 or ISO-8859-5. Since in fact there's no requirement on the GUI font we use, it's currently hard to impossible (for 3rd party translations using different char sets) to fix this.

There's a similar problem with filenames reported as bug #1193732 "GUI: non-english chars in directory names not supported".

comment:2 by bluegr, 7 years ago

This is in fact a very old bug and dates back to 2008 (bug #1946611):
https://sourceforge.net/tracker/?func=detail&aid=1946611&group_id=37116&atid=418820

Closing this one as duplicate. I'll update the description of the other bug with information from this one

comment:3 by bluegr, 7 years ago

Resolution: duplicate
Status: newclosed

comment:4 by digitall, 12 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.