Opened 7 years ago

Closed 7 years ago

#6060 closed defect (fixed)

SOLTYS: text lines missing

Reported by: SF/robertmo Owned by: Strangerke
Priority: normal Component: Engine: CGE
Keywords: script Cc:
Game: Soltys

Description

WinXP-32bit Win7-64bit
Win32 ScummVM Daily Snapshot (build from repository, 6521K Win32 exe file, last update: June 24, 2012, 12:25 am)
Provided by ScummVM Team member Travis 'Kirben' Howell, updated several times daily

missing text balloons in polish version cause of:
03pin.spr - no enter at the end of file
03grzyb1.spr - no enter at the end of file

right click on fungus on the right (the ones on the left work) - wrong text
walk to penguin (left click) and try to take it (right click) - no text

Ticket imported from: #3537527. Ticket imported from: bugs/6060.

Attachments (1)

soltys_saves.zip (61.3 KB) - added by SF/robertmo 7 years ago.
use penguin pl

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by SF/robertmo

Attachment: soltys_saves.zip added

use penguin pl

comment:1 Changed 7 years ago by SF/robertmo

Component: Engine: CGE
Game: Soltys

comment:2 Changed 7 years ago by wjp

Summary: text lines missingSOLTYS: text lines missing

comment:3 Changed 7 years ago by Strangerke

Owner: set to Strangerke

comment:4 Changed 7 years ago by Strangerke

Caused by the use of readLine. Code should be reworked to avoid it.

comment:5 Changed 7 years ago by Strangerke

Fixed in 80388527ea891bc9c44cd11ff31afefb253d3eaa
Could you please confirm?

comment:6 Changed 7 years ago by Strangerke

Resolution: fixed

comment:7 Changed 7 years ago by SF/robertmo

this one is fixed -> walk to penguin (left click) and try to take it (right click)
this one is still not fixed -> right click on fungus on the right (the ones on the left work) - wrong text
the text should be the same as for the left fungus, but instead we got the random message
(compare with english version)

comment:8 Changed 7 years ago by Strangerke

Corrupted savegame - Works well when played from the beginning

comment:9 Changed 7 years ago by Strangerke

Status: newclosed
Note: See TracTickets for help on using tickets.