Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6055 closed defect (fixed)

SCUMM: FT Missing Dialogue Line

Reported by: SF/tikitang Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

ScummVM Version 1.4.1
Language of game: English
Platform: Windows (same issue on both)
Game Version: CD-ROM "Version B"
Details: When Ben first enters Mine Road and meets Father Torque, Ben should exclaim "Father Torque!" when his bike pulls up along side Torque's in what would have been "Fight Mode" if Father Torque was an enemy biker. However, for some reason this piece of dialogue is skipped. Ben is silent and says nothing until the game cuts to "Dialogue Mode".

Save file attached --- Ben @ Poyahoga Gorge and ready to enter Mine Road for first time.

Ticket imported from: #3536645. Ticket imported from: bugs/6055.

Attachments (1)

ft.s02 (22.9 KB ) - added by SF/tikitang 7 years ago.

Download all attachments as: .zip

Change History (7)

by SF/tikitang, 7 years ago

Attachment: ft.s02 added

comment:1 by SF/mthreepwood, 7 years ago

Summary: Missing Dialogue LineSCUMM: FT Missing Dialogue Line

comment:2 by digitall, 7 years ago

Tested with savegame on latest Git master on Linux x86_32. Replicated bug.
Tried with "Version A" game variant as well, bug still present.

Tried with Win32 versions to do coarse bisection. Bug replicated on v1.4.1 and v1.4.0.
Can't load savegame in earlier versions as the save format has changed.

Will try using the bootparams to jump to the relevant point and see if I can replicate:
http://wiki.scummvm.org/index.php/Boot_Params#Full_Throttle

comment:3 by digitall, 7 years ago

Using Boot Param 550 i.e. ./scummvm -d0 -b 550 ft, I am able to replicate this. Have tried all version on Win32 back to 0.7.0 and they all exhibit a missing line here. It looks like Ben is stuck facing right when he enters the overhead view i.e. fight sequence, so never plays the "Father Torque!" line and animation of speaking.

I would have continued to earlier versions (FT support was added in 0.2.0), but versions prior to 0.7.0 crash with various SDL segfault or script assertions when you try to use this bootparam, so it will be necessary to play the game through, use a very old savegame or another bootparam value to replicate this, but I suspect this has always been broken.

tikitang: It will require a SCUMM engine developer to disect the scripts for this scene and work out what is going wrong here, which will likely take some time. Please be patient and standby.

comment:4 by digitall, 7 years ago

The missing line and animation of Ben can be seen in this video at 14m30s:
https://www.youtube.com/watch?v=g0BStojikmY

comment:5 by eriktorbjorn, 7 years ago

Apparently, the condition for setting up the scene had been accidentally inverted so that it was calling prepareScenePropScene() over and over (presumably causing it to stall) instead of just once. I've committed a fix for it. (I don't know much about INSANE, but fortunately sev was at hand to confirm that it was the correct fix.)

comment:6 by eriktorbjorn, 7 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.