Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6045 closed defect (fixed)

DREAMWEB: doors don't play "open" sound when opening

Reported by: SF/banjo-oz Owned by: digitall
Priority: normal Component: Engine: Dreamweb
Keywords: Cc:
Game: Dreamweb

Description

ScummVM: 1.5.0git3018-g5a245bd
Language: English
Game version: CD ("talkie") UKV original 1994 release
Platform: Windows x64

Walking around Eden's apartment at the start, when you walk up to a 'normal' door (the door to the bathroom, the door out of the garage) it does NOT make the proper "open" sound effect when it opens for you. I tested this several times, walking back and forth through the rooms, and neither door once played sound on opening. They do make sound on closing, however.

I double-checked to make sure I wasn't misremembering, but sure enough: under DOSBox, the doors do make sound when they open (as I remembered them doing so under real DOS).

Ticket imported from: #3531635. Ticket imported from: bugs/6045.

Change History (11)

comment:1 Changed 7 years ago by digitall

Owner: set to digitall

comment:2 Changed 7 years ago by digitall

banjo-oz: Thank you for the bug report. I can not replicate this here with the latest Git master, but I suspect I know the cause.

Please can you confirm this for me by running as ./scummvm -d 1 in a command window, skip the intros and then walk Ryan to the Elevator and use the button. The Elevator should then make a sound as the door opens, then close ScummVM.

The last few lines in the log _should_ read:
playChannel0(index:15, repeat:255)
playSound(channel:0, id:15, loops:255)
playChannel1(index:2)
playSound(channel:1, id:2, loops:1)

If you could let me know what you observe and what the last 5-10 lines in the output log are...

comment:3 Changed 7 years ago by wjp

The door-opening sound is index 0, which we seem to be handling wrong by interpreting it as "no sound" in soundHandler. (Not sure why.)

comment:4 Changed 7 years ago by SF/banjo-oz

What wjpalenstijn makes sense; the elevator does make a sound when the door opens and closes, but "normal" doors (such as the one to the bathroom) only makes sound on closing.

With a new game, walking straight into the bathroom (through the door), over to the toilet, then back through the door and out into the main living area, this is the log:

playChannel1(index:0)
playChannel1(index:1)
playSound(channel:1, id:1, loops:1)
playChannel1(index:0)
playChannel1(index:1)
playSound(channel:1, id:1, loops:1)

The door sound is audible on closing ("playChannel1(index:1)") each time, but not on opening ("playChannel1(index:0)").

comment:5 Changed 7 years ago by digitall

Ah, can now replicate with the bathroom door. As wjp indicated, this is because the current Soundhandler code incorrectly interprets the index 0 as no sound... Will have to look at further changes to the Dreamweb sound code to better match the original behaviour.

comment:6 Changed 7 years ago by digitall

banjo-oz: Have commited fix as 7d29e4017d37f7aee4035b3d7288c8c5478633be.
If you can download the next daily build and confirm this here please:
http://www.scummvm.org/downloads/#daily

This shouldn't cause any regressions i.e. of your previous bugs, but if you could do a full playtest paying special attention to sound events and report any other bugs, that would be helpful. Thanks.

comment:7 Changed 7 years ago by digitall

Resolution: fixed
Status: newpending

comment:8 Changed 7 years ago by SF/banjo-oz

I can confirm that the opening door sound is fixed with that release.

Will report when I have time for a full playthrough if I find any more bugs!

comment:9 Changed 7 years ago by SF/banjo-oz

Status: pendingnew

comment:10 Changed 7 years ago by wjp

Thanks for the report and verifying it now works!

comment:11 Changed 7 years ago by wjp

Status: newclosed
Note: See TracTickets for help on using tickets.