Opened 7 years ago

Closed 7 years ago

#6035 closed defect (fixed)

DREAMWEB: No speech playing in CD version

Reported by: SF/banjo-oz Owned by: digitall
Priority: normal Component: Engine: Dreamweb
Keywords: Cc:
Game: Dreamweb

Description

ScummVM: 1.5.0git2944-g398d0ff
Platform: Windows x64
Language: English
Game version: CD ("talkie")

There is no speech in the game, only music/SFX and subtitles.

I am not sure if there was a "non-speech" CD release (or if only the floppy and Amiga version lacked speech), but the CD version I have and tested with is definitely a "full talkie" version.

Using DOSbox (or real DOS), I get voiced narration and conversations (e.g. opening intro voice-over, speech when examining things or talking to other characters, etc.), but under ScummVM I get no speech at all. Just subtitles (even though I have ScummVM set to 'speech' and it works fine with other games like Full Throttle and Monkey Island).

If you need further info about my specific CD version and/or files on it (in case this is a case of ScummVM simply not detecting a "talkie" CD version correctly - it detects mine as "Dreamweb", incidentally), let me know and I'll be happy to help get one of my favourite games of all time working properly! :)

Ticket imported from: #3526483. Ticket imported from: bugs/6035.

Attachments (2)

dreamweb_cd_md5.txt (30.4 KB ) - added by SF/banjo-oz 7 years ago.
Dreamweb PC-CDROM ("UKV") file list and MD5s
Dreamweb_UKV_originalrelease_md5deep.txt (17.2 KB ) - added by SF/banjo-oz 7 years ago.
Dreamweb PC-CDROM (original UK release) results of MD5deep

Download all attachments as: .zip

Change History (22)

comment:1 by SF/banjo-oz, 7 years ago

Priority: normalhigh
Summary: No speech in speech versionDREAMWEB: no speech playing CD version

comment:2 by lordhoto, 7 years ago

Please don't mess with the priority setting, it's only for internal use.

comment:3 by lordhoto, 7 years ago

Priority: highnormal

comment:4 by lordhoto, 7 years ago

Summary: DREAMWEB: no speech playing CD versionDREAMWEB: No speech playing in CD version

comment:5 by SF/banjo-oz, 7 years ago

Sorry, that was by accident... this is the first "bug report" I've ever submitted here. As I said, let me know if I can help fixing this problem.

comment:6 by digitall, 7 years ago

banjo-oz: Have just tested with latest Git master on Linux x86_32 with my Dreamweb English CD version.
No problem with speech here and the detection still works correctly.

Two points to progress this:
1. Can you please attach a text file to this bug containing a file listing of your Dreamweb CD datafiles with file MD5sums. The output of a tool such as http://md5summer.org/ would be optimal.
2. Is your version detected as "Dreamweb (CD/DOS/English)" or "Dreamweb (DOS/English)" ?

by SF/banjo-oz, 7 years ago

Attachment: dreamweb_cd_md5.txt added

Dreamweb PC-CDROM ("UKV") file list and MD5s

comment:7 by SF/banjo-oz, 7 years ago

1) I've attached a list of the files created using MD5summer as requested, scanned directly from my original CD-ROM. Let me know if you need anything else.

2) My game/files are detected as "Dreamweb (DOS/English)" and NOT "Dreamweb (CD/DOS/English)".

This suggests the bug is just improper detection, I presume? I'm not familiar with other Dreamweb CD releases out there, I'm afraid; my Australian retail-bought 1994 disc is labeled "UKV" (like this one: http://www.mobygames.com/game/dos/dreamweb/cover-art/gameCoverId,178818/) but I'm now wondering if there were versions for other countries (someone mentioned a (presumably later released) Australian 'censored' version once, but mine certainly isn't).

comment:8 by SF/banjo-oz, 7 years ago

(sorry, couldn't find an 'edit' function here!)

If it helps...

A check at Moby Games revealed a second (jewel case only?) english Dreamweb CD release in the UK, with a red and black (different to my black and silver) CD-ROM disc. Perhaps a different version?

I do know there was also a "white label" re-release in Australia (and presumably the UK) much later.. I used to own it too, but lost it in a move and actually never opened/played it).

comment:9 by digitall, 7 years ago

banjo-oz: Thank you for this information. I have the UK Virgin White Label CD release and have compared the file MD5sums. Most match, but there are some differences. The following 15 files have different checksums:
DREAMWEB.EXE
DREAMWEB.G03
DREAMWEB.G08
DREAMWEB.P01
DREAMWEB.P02
DREAMWEB.R02
DREAMWEB.R08
DREAMWEB.R11
DREAMWEB.R13
DREAMWEB.R21
DREAMWEB.R45
DREAMWEB.T24
DREAMWEB.T83
DREAMWEB.T84
SPEECH/R23C0014.RAW

and DREAM.WAV is not present, though DREAMWEB.WAV is probably the same file.

This could be due to a bad media copy so you should recopy from your original CD to check if the files change... but this is probably just due to a different variant. Since the detection is done on the DREAMWEB.R00 and R02 files and your R02 is unknown, the detector is probably acheiving a fallback match and mistakenly getting a floppy rather than CD match.

Could you run ScummVM from a CMD line window? This will enable the output console window which will contain any messages about inaccurate detection/fallback when you detect your version. i.e.
1. Run ScummVM from CMD Window
2. Detect your Dreamweb CD version
3. Post any message from the text console window here... You are looking for a message that starts "Your game version appears to be unknown.... " and ends with some lines of hashes for your version...

comment:10 by digitall, 7 years ago

This information will allow us to add a specific detection entry for your variant version.

comment:11 by SF/banjo-oz, 7 years ago

I recopied the files from my original "UKV" CD just in case... same result: detected as the floppy version. (I MD5'ed the original CD, not the files themselves, incidentally, if that makes a difference).

Now, out of curiosity (and before I read your reply) I tried another version of Dreamweb (CD-ROM) I found which DID detect as the CD version correctly and plays with voices. This obviously must be the "White Label" re-release you tested with, as it has the same layout, files and filenames as yours (e.g. DREAMWEB.WAV instead of DREAM.WAV; incidentally both are indeed the same 'bonus audio track'), and with different files/MD5s to my original CD.

I also found and tried the "censored" version (David Crane has pants on!), which detected with ScummVM as the CD version also (and played with voices)... but interestingly detected correctly as the "US" version as well. The US CD has some file differences too.

So, seems I was right about there being at least three different releases: a UK original (mine), a UK re-release (yours) and a US censored release. Wonder if there were any more? I think it was released in German and French too.

Anyway... I've been trying to get the info you need from my original UK CD, but I'm not sure how to get that info in the console. I start ScummVM from the command line, add the game (it detects as the non-cd version, as before)... but the only info in the console window is the usual "SDL mixer output buffer" error I always get there... nothing about not finding the game version. I also tried running the game and opening the debug console/log... it says "gameid: dreamweb" and runs the DREAMWEB engine. No errors.

Please let me know if there's something I'm missing doing to get the right console info to appear, as I'd love to help you solve this!

PS When you've fixed auto-detection of my UK original release, will you make the White Label detection name something different (like the US release is); eg. dreamweb-cd-wl) or something to make it stand out from the original release with the different files/structure?

comment:12 by digitall, 7 years ago

banjo-oz: Thank you for the response, however two points:
1. As a point of netiquette, this is a bug tracker, not a discussion forum.
We provide forums at http://forums.scummvm.org/ and an IRC channel at #scummvm on freenode, if you wish to talk
to fans or the developers in an informal manner, but on the tracker, please keep responses succinct and on topic.
2. I'm sure that the three alternative versions you tried were borrowed from friends, and not downloaded from random
sites, as the project has a zero tolerance policy of warez. Apart from the legal aspect detailed below, such versions
are often corrupted and waste our time with invalid bugs:
http://wiki.scummvm.org/index.php/Copyright_FAQ

Since the detector is not indicating a fault or I can't get that from you, please use the procedure detailed in the following to generate the detection hashes manually and attach them as a text file to this bug?:
http://wiki.scummvm.org/index.php/Reporting_unknown_MD5_checksums

(Dreamweb uses the default of 5000 bytes)

by SF/banjo-oz, 7 years ago

Dreamweb PC-CDROM (original UK release) results of MD5deep

comment:13 by SF/banjo-oz, 7 years ago

Sorry for being too "informal"; unlike many, I tend to conduct myself on the "net" as I do in real life: friendly and relaxed. I'm just trying to help you guys here, using my love for this game and trying to provide information that I felt you did not know or have access to. I didn't think the forums would be the place to give this (IMO, on-topic) info. My mistake. :(

Since no fault is indicated in the ScummVM console window/log, so I've attached what I hope is the information you need, gained from MD5deep (using size = 5000). Let me know if it's not what you were asking for and I'll happily try again.

comment:14 by SF/banjo-oz, 7 years ago

Just checking the info I sent was what was needed, or if you need anything else logged?

comment:15 by digitall, 7 years ago

banjo-oz: Don't be sorry. Learn. I have no problem with "informal", but this is a bug tracker, not a discussion forum.
Be precise and on topic or you are wasting my time. See http://www.catb.org/~esr/faqs/smart-questions.html for a fuller explanation.

You have now provided sufficient information. The problem is that ScummVM is currently doing detection on just the DREAMWEB.R00 and R02 files as this was thought to be sufficient to distinguish all the versions.
However, your UKV CD version has identical DREAMWEB.R00 and R02 files (as far as the detection MD5sums are concerned) to the International Floppy release causing a collision in detection.

I will look at modifying and extending the detection entries to avoid this. Please standby.

comment:16 by digitall, 7 years ago

Have amended the detection entries in commit e23ac65799b47babe2cfb88d5436a742278f6b02.

banjo-oz: Please test with the next daily build to see if this is now fixed:
http://www.scummvm.org/downloads/#daily

comment:17 by digitall, 7 years ago

Owner: set to digitall
Resolution: fixed
Status: newpending

comment:18 by SF/banjo-oz, 7 years ago

UKV original release is now detected as "dreamweb-cd". Thanks.
However, there is another new bug only for this version that I've added as a new bug entry (since this one is technically "fixed" now).

comment:19 by SF/banjo-oz, 7 years ago

Status: pendingnew

comment:20 by digitall, 7 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.