Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6021 closed defect (outdated)

BASS: Characters are stuck after load

Reported by: SF/capiscuas Owned by: digitall
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

I was wondering if the current situation of the attached Scummvm saving is a crash in the game or some Scummvm bug, because the characters are not reacting to the click of the mouse to move, they are basically stuck in the same position.

Ticket imported from: #3517746. Ticket imported from: bugs/6021.

Attachments (1)

saves.zip (13.9 KB ) - added by SF/capiscuas 8 years ago.
Saves of Beneath the Steel Sky

Download all attachments as: .zip

Change History (17)

by SF/capiscuas, 8 years ago

Attachment: saves.zip added

Saves of Beneath the Steel Sky

comment:1 by SF/capiscuas, 8 years ago

Same error in ScummVM for android, and ScummVM for linux ScummVM 1.3.1 (Aug 5 2011 17:23:32) Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth

I'm using the bass-cd-1.2.zip version from Sourceforge repository.

comment:2 by digitall, 8 years ago

Summary: Characters are stuck withot movingBASS: Characters are stuck after load

comment:3 by digitall, 8 years ago

Can replicate this with the attached savegame on Linux x86_32 and latest Git master, but not from save/load.

I would suspect that the savegame state is corrupt, probably due to autosave conflict issues in save slot #0 with pre v1.4.0 binaries. I can investigate as to how the savestate is corrupt, but that doesn't really help us work out why...

capiscuas: Can you reliably replicate this from a clean new game? If so, avoid using save slot #0 and see if the same bug occurs...

comment:4 by SF/capiscuas, 8 years ago

is there a way I can find savegames of that game, cause I can't spend the time playing again from 0 to arrive to the same place.

comment:5 by digitall, 8 years ago

Status: newpending

comment:6 by digitall, 8 years ago

capiscuas: NO.. The point here is to try to replicate this issue from a clean start on a single platform with the latest stable i.e. v1.4.1 and/or latest Git master.

Rereading your initial bug report, have you been moving savegames back and forth between Android and Linux?

We don't really guarantee that savegames are portable between platforms or releases... although they usually are.

If you are unwilling to do this testing, then I will have to conclude this is probably a savegame corruption due to this kind of mixing and close the bug as invalid.

comment:7 by SF/capiscuas, 8 years ago

Hmm, I must apologize but honestly I cannot take the time to replicate it again so I will understand u invalidate it. About the mixing the savegames, the corruption happened already in the android Scummvm while I was playing it, then since it was stuck, I decide to copy the savegames into linux to see if it was also stuck there.

So I can confirm that the corruption was not due to move it between systems. Thanks.

comment:8 by SF/capiscuas, 8 years ago

Status: pendingnew

comment:9 by digitall, 8 years ago

It is no problem, but these kind of issues are very hard to pin down the cause from the savestate corruption afterwards.

However, I have done some checking and this looks like a duplicate of bug #3487117 "BASS: Save game corruption on Android (and other platforms?)": https://sourceforge.net/tracker/?func=detail&aid=3487117&group_id=37116&atid=418820

This has now been fixed in Git and this fix will be included in future releases. Please use a daily build until then: http://buildbot.scummvm.org/builds.html

Closing this bug as Out of Date.

comment:10 by digitall, 8 years ago

Owner: set to digitall
Resolution: outdated
Status: newclosed

comment:11 by SF/capiscuas, 8 years ago

thanks a lot for the info.

comment:12 by SF/capiscuas, 8 years ago

Owner: digitall removed
Resolution: outdated
Status: closednew

comment:13 by SF/capiscuas, 8 years ago

I did tried with the latest sky and scummvm .apk but still the scene seems blocked. nevermind.

comment:14 by digitall, 8 years ago

Owner: set to digitall
Resolution: outdated
Status: newclosed

comment:15 by digitall, 8 years ago

capiscuas: To be clear... Your savegame is _corrupted_ and will not be recoverable. If you continue using v1.4.1 or previous on Android, this is likely to happen again from a new game. If you use a daily build which incorporates this fix, then from a new game, this should not occur again.

If you see this bug again in that scene after removing the corrupted savegames and starting from a new game, please report this, but not if you are loading the corrupted savegames...

comment:16 by SF/capiscuas, 8 years ago

Got it! Thks!

Note: See TracTickets for help on using tickets.