Opened 9 years ago

Closed 9 years ago

Last modified 2 years ago

#6020 closed defect (fixed)

Wii - Noisy cutscene audio in Toonstruck & Feeble Files

Reported by: (none) Owned by: DrMcCoy
Priority: normal Component: Port: Wii
Keywords: Cc:
Game:

Description

The audio is noisy/scratchy/popping when cutscenes are played in Feeble Files and Toontruck in build 526188.

It works fine in the stable 1.3.1 build

Ticket imported from: #3516671. Ticket imported from: bugs/6020.

Change History (14)

comment:1 by (none), 9 years ago

Forgot to mention that the games work fine on the same build PC version.

comment:2 by digitall, 9 years ago

Owner: set to dhewg

comment:3 by digitall, 9 years ago

Assuming you mean the current Git master i.e. as of commit db52618833920648b3ced9e2e8a7d692a4aba08f and that you are using the current nightly build.

Since Feeble Files and Toonstruck use different engines i.e. AGOS and Toon respectively, this is probably an issue with sound changes, but as with all embedded ports, bisecting to locate the regression is slow..

dhewg: Any chance of a v1.4.0 and v1.4.1 stable build for Wii? As this would help...

comment:4 by digitall, 9 years ago

Reviewed the code with fuzzie.

Both of these engines are using SMK files for the cutscenes here.

The video/smk_decoder.cpp was migrated to Common::BitStream in commit c9a59235b202d96aae2f295af7404d1b22e60bcf since v1,3,1: Author: Sven Hesse <drmccoy@users.sourceforge.net> 2011-08-28 12:43:50

VIDEO: Use the BitStream implementation in Common

Removing/Replacing the custom implementation

But this code doesn't look quite correct in the Audio code changes. It doesn't look correct for Endian safety and may break Big Endian i.e. Wii

Also, the 1 byte padding to the audio buffer looks to be inserted in the audio buffer which may also be causing the "popping"...

comment:5 by DrMcCoy, 9 years ago

The endian issue should be fixed in rev 7eef262 now. Just me being brain-dead. :/

But the 1-byte padding really shouldn't matter. It should not make it into the buffer, it's just an extra padding to keep the Huffman tree building from overreaching. In any case, that should then be audible on little endian systems too, which it wasn't.

comment:6 by DrMcCoy, 9 years ago

Owner: changed from dhewg to DrMcCoy
Status: newpending

comment:7 by digitall, 9 years ago

drmccoy: Thanks for fixing this.

yardape8000: Please can you download a new daily build which will include this correction and see if this bug is now fixed: http://buildbot.scummvm.org/builds.html

comment:8 by (none), 9 years ago

Status: pendingnew

comment:9 by (none), 9 years ago

I will test it when I get home tonight. Thanks for looking into so quickly.

comment:10 by (none), 9 years ago

Looks like the snapshots are a few days behind (Apr 11), so I'll have to wait until the changes make it in and report back.

wii-master-3e47203d is the latest.

comment:11 by (none), 9 years ago

Awesome! Thanks for the quick fix. Both games are working fine now.

Keep up the great work.

comment:12 by digitall, 9 years ago

Resolution: fixed
Status: newclosed

comment:13 by digitall, 9 years ago

yardape8000: No problem. Thank you for discovering and reporting this bug... Closing bug as fixed.

comment:14 by digitall, 2 years ago

Component: Port: Wii
Note: See TracTickets for help on using tickets.