Opened 12 years ago

Closed 2 years ago

#6011 closed defect (fixed)

SCUMM: Loom (EGA) - Minor glitches when restoring

Reported by: SF/kurufinwe Owned by: athrxx
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Loom


Using ScummVM 1.5.0git2684-g5ae2543 on Win 7 64 bit. Playing Loom (EGA, DOS, English).

Loading the attached savegame (in Hetchel's tent) exhibits two minor glitches:

1) As can be seen on the save's thumbnail, the dye pot was selected when the game was saved. When restoring, the location where the selected item should appear is black. Hovering over the other selectable items (the sheets, the basket...) does not display a close-up of them in the active item location. Clicking on the dye pot prints the words "dye pot" on the item location, but does not display the picture. Clicking anywhere else fixes everything. So basically, the game behaves as if the dye pot were selected as active item, but does not display its picture in the active items box.

2) As can also be seen in the save's thumbnail, the flask had fallen on the table when the game was saved, but when restoring it is hanging in mid-air, and the neck of the flask is floating in the middle of nowhere (exactly where it should be if the flask were in its fallen position). Exiting the room and re-entering fixes the problem. I'm attaching a screenshot showing the bug after restoring.

I didn't know if I should have made two separate bug reports for these two glitches. Please let me know if you want me to file a separate bug for the second issue.

Ticket imported from: #3506554. Ticket imported from: bugs/6011.

Attachments (2)

loom-ega.s02 (16.3 KB ) - added by SF/kurufinwe 12 years ago.
Save in Hetchel's tent
scummvm00029.png (56.8 KB ) - added by SF/kurufinwe 12 years ago.
Screenshot of the second bug

Download all attachments as: .zip

Change History (11)

by SF/kurufinwe, 12 years ago

Attachment: loom-ega.s02 added

Save in Hetchel's tent

by SF/kurufinwe, 12 years ago

Attachment: scummvm00029.png added

Screenshot of the second bug

comment:1 by digitall, 12 years ago

kurufinwe: Thank you for this bug report. To help investigate this, could you confirm the following: 1. Does this occur with the current stable version i.e. v1.4.1 ? 2. If so, could you try previous versions to at least 0.9.1 to see if this worked in a previous version? 3. Could you try playing this with the original interpreter under DOSBox and confirm that these bugs are not present in the original?

comment:2 by digitall, 12 years ago

Also, attaching a text file containing a file listing with file MD5sums of your LOOM Floppy datafiles to this bug would be useful to check your exact version and eliminate corruption in datafiles as a cause. The output of a tool such as would be optimal.

comment:3 by SF/kurufinwe, 12 years ago

The two glitches seem really unrelated, so I'll treat them separately (I really should have made two separate bug reports).

Glitch #1:

First, I should mention that this happens everywhere, every time that the game is saved with an item "active" (i.e. displayed in the selected item box next to the distaff, or whatever you want to call it). ScummVM's behaviour changed between version 0.5.1 and 0.6.0. Neither behaviour matched the original interpreter's, but the older one was definitely better than the current one.

Original interpreter: Whenever F5 is pressed, the selected item gets deselected (you can briefly see the selected item box turn black before the menu appears). It is thus not saved. When restoring the game (or just leaving the menu after saving), the game behaves as if no item were selected.

ScummVM up to v. 0.5.1: The information about the selected item is saved and restored correctly. When restoring the game, the picture of the selected item is displayed in the selected item box, though its name is not displayed until the item is clicked on again (as if Bobbin were still walking towards the item). Clicking anywhere else unselects the item, which is the normal behaviour of the game.

ScummVM 0.6.0 and newer: Exactly the same as the previous ScummVM versions, except that the picture of the item is not displayed in the selected item box. Clicking on the item displays its name (but still not the picture). Clicking anywhere else unselects the "invisible" item and returns everything to normal.

This is really a very minor glitch which just goes away by clicking anywhere, but it's a bit surprising when you restore a save, move the pointer around and it seems like there's no hotspot anywhere (since selectable items do not appear when hovering over them when another item is currently selected).

(This is extremely hard to explain in simple words, especially if you don't have the precise way the game works in mind. I hope that still makes some sense.)

comment:4 by SF/kurufinwe, 12 years ago

Glitch #2:

This doesn't happen in the original interpreter: the flask is correctly restored in the position that it was in.

It seems to happen with every version of ScummVM up to 0.4.0. I couldn't test with 0.3.0b, which seems to crash on my computer.

I'll look into getting the md5 list, though since it doesn't occur with the original interpreter (and goes away when leaving and re-entering the room) I guess it's probably not a problem with a corrupt file.

comment:5 by eriktorbjorn, 12 years ago

I can reproduce this as well. One possibility is that because the original save/load dialog was scriped, we don't do everything those scripts do before and/or after saving/restoring. Perhaps there's a script that needs to be run, or something like that.

comment:6 by bonki, 6 years ago

Just for the record, this still occurs in v2.0.0.

comment:7 by raziel-, 4 years ago

Summary: LOOM: Minor glitches when restoringSCUMM: Loom (EGA) - Minor glitches when restoring

comment:8 by athrxx, 2 years ago

There is now a pull request with an attempt to fix this.

Please test if you have time...

comment:9 by athrxx, 2 years ago

Owner: set to athrxx
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.