Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#601 closed defect (fixed)

MI2: unable to enter codes - key assign

Reported by: SF/cruchot Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

When launching MI2, I first have to enter the game
codes, but when I try to enter them (either with numpad
or keyboard) scummvm saves the game state
to 'monkeyX.s0X', where X is the number I typed.

I got the scummvm 0.2.83 win32 daily snapshot from
November 28, 2002, 7:07 pm.

The problem is (I think) with a key assignment: the
numeric keys are assigned to quick-save slots...

Ticket imported from: #645721. Ticket imported from: bugs/601.

Change History (5)

comment:1 by fingolfin, 17 years ago

What keyboard do you have (US layout) ?
Entering codes like this works just fine over here (on OS X
with a german keyboard layout) in MonkeyVGA, don't see why
MI2 should cause troubles.

Ctrl-NUM and Alt-Num trigger save/load normally. Weird.

comment:2 by SF/cruchot, 17 years ago

I think it's due to the fact that I use a belgian keyboard.
On those keyboards (and french ones also), the numeric keys
are accessible by pressing SHIFT+key (--> shortcut for
quicksave), and without SHIFT, we have special characters
like & " and so on...

comment:3 by fingolfin, 17 years ago

Status: newclosed

comment:4 by fingolfin, 17 years ago

I changed the quicksave shortcut from shift-NUM to alt-NUM,
so this should work now.

comment:5 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Note: See TracTickets for help on using tickets.