Opened 8 years ago

Closed 8 years ago

#5998 closed defect (fixed)

TSAGE: Blue Force crashes on picking up cartridge

Reported by: SF/draky95 Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Blue Force

Description

Hello

Just trying to complet Blue Force with the last daily build.
Random crashes occur but restarting and re-loading seems ok but now I'm completely stuck as it crashes every time at same place.

Place : in the trailer, on bikini hut place.
Inside, I try to take cartridges or boot and then crash.
Savegames provided, the last one "bikini caravane" is the crash place : load and try to pick cartridge (above cabinet).
Build is : 1.5.0git2618-g657206b for Win32 (running on XP)

Ticket imported from: #3495809. Ticket imported from: bugs/5998.

Attachments (2)

blueforce_savegames.zip (170.3 KB ) - added by SF/draky95 8 years ago.
Savegames for Blue Force, last crashes
BlueForce_MD5.txt (510 bytes ) - added by SF/draky95 8 years ago.
Blue Force files MD5

Download all attachments as: .zip

Change History (10)

by SF/draky95, 8 years ago

Attachment: blueforce_savegames.zip added

Savegames for Blue Force, last crashes

comment:1 by digitall, 8 years ago

Summary: Blue Force crashTSAGE: Blue Force crashes on picking up cartridge

comment:2 by digitall, 8 years ago

draky95: Will attempt to replicate this.
In the meantime, could you please attach a text file to this bug with a file listing of your Blue Force game datafiles from the game CD with file MD5sums.

This will allow us to eliminate corrupted datafiles as a possible cause and exactly identify your released version.
The output of a tool such as http://md5summer.org/ would be optimal.

comment:3 by digitall, 8 years ago

Replicated with attached savegame #8, Blue Force (CD/DOS/English) on Linux x86_32.
This is not a segfault, but an engine error about with the message:
"Unknown message 930 line -1!"

Checked for memory issues with Valgrind. None associated, though there are two messages associated with Dirty Rects on Cursor surface:
==14275== Conditional jump or move depends on uninitialised value(s)
==14275== at 0x8E9EF3A: TsAGE::GfxSurface::addDirtyRect(TsAGE::Rect const&) (
graphics.cpp:284)
==14275== by 0x8E9F568: TsAGE::GfxSurface::fillRect(TsAGE::Rect const&, int)
(graphics.cpp:388)
==14275== by 0x8E8CBED: TsAGE::SceneText::setup(Common::String const&) (core.cpp:3027)
==14275== by 0x8E8829F: TsAGE::SceneItem::display(int, int, ...) (core.cpp:1708)
==14275== by 0x8E88660: TsAGE::SceneItem::display2(int, int) (core.cpp:1757)
==14275== by 0x8FFB856: TsAGE::BlueForce::SceneExt::display(TsAGE::CursorType) (blueforce_logic.cpp:802)
==14275== by 0x8E8899B: TsAGE::SceneHotspot::startAction(TsAGE::CursorType, TsAGE::Event&) (core.cpp:1803)
==14275== by 0x8FFE667: TsAGE::BlueForce::NamedHotspot::startAction(TsAGE::CursorType, TsAGE::Event&) (blueforce_logic.cpp:1367)
==14275== by 0x8E90AA0: TsAGE::SceneHandler::process(TsAGE::Event&) (core.cpp:4181)
==14275== by 0x8FFC32F: TsAGE::BlueForce::SceneHandlerExt::process(TsAGE::Event&) (blueforce_logic.cpp:985)
==14275== by 0x8E90EA1: TsAGE::SceneHandler::dispatch() (core.cpp:4252)
==14275== by 0x8E9049E: TsAGE::GameHandler::execute() (core.cpp:4057)

by SF/draky95, 8 years ago

Attachment: BlueForce_MD5.txt added

Blue Force files MD5

comment:4 by SF/draky95, 8 years ago

Just added the MD5 text file with all sums from my files.

Tried to reproduce in Linux but... last build is 1.3.1 so...

comment:5 by digitall, 8 years ago

draky95: Thanks for the file listing.

Please don't worry about trying to replicate under Linux. That technical comment was intended to aid the Tsage engine team when they look at this bug.
Though the current stable release is v1.4.1 and is available for most Linux distributions/packaging formats and as source, but may not have been updated in some distribution's official package repositories yet:
http://www.scummvm.org/downloads/

comment:6 by digitall, 8 years ago

Owner: set to dreammaster

comment:7 by dreammaster, 8 years ago

The latest daily build should fix the problem. You just have to either load an earlier savegame, or leave the trailer and return. You should then be able to get the catridges correctly. I've also fixed the Valgrind warning.

comment:8 by dreammaster, 8 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.