Opened 8 years ago

Closed 8 years ago

Last modified 12 months ago

#5990 closed defect (invalid)

GROOVIE: Global constructors degrades portability

Reported by: fingolfin Owned by:
Priority: normal Component: Engine: Groovie
Keywords: Cc:
Game:

Description

The GROOVIE engine makes use of global constructors, which reduces portability. Here's the relevant error / warning from clang.

C++ engines/groovie/script.o
../../engines/groovie/script.cpp:1681:28: error: declaration requires a global constructor
[-Werror,-Wglobal-constructors]
Script::OpcodeFunc Script::_opcodesT7G[NUM_OPCODES] = {
^ ~
../../engines/groovie/script.cpp:1777:28: error: declaration requires a global constructor
[-Werror,-Wglobal-constructors]
Script::OpcodeFunc Script::_opcodesV2[NUM_OPCODES] = {
^ ~
2 errors generated.
make: *** [engines/groovie/script.o] Error 1

Ticket imported from: #3492137. Ticket imported from: bugs/5990.

Change History (3)

comment:1 by fingolfin, 8 years ago

Resolution: invalid
Status: newclosed

comment:2 by fingolfin, 8 years ago

This was with Apple clang version 3.0 (tags/Apple/clang-211.10.1). However, I cannot reproduce this with a current trunk build of clang either, so I am closing this as invalid. Sorry for the confusion!

comment:3 by digitall, 12 months ago

Component: Engine: Groovie
Note: See TracTickets for help on using tickets.