Opened 8 years ago

Closed 6 years ago

#5982 closed defect (fixed)

SCI: LONGBOW: Crazy intruments in intro (AdLib)

Reported by: SF/kurufinwe Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Conquests of the Longbow

Description

Using ScummVM 1.5.0git2420-g975801b on Win 7 64 bit. Playing Conquests of the Longbow (DOS, English, v 1.0 with official Sierra patch).

During the last part of the intro, when the game returns to the minstrel after Richard\'s confrontation with Leopold, certain instruments are completely wrong (the tune is right, just the type of instrument playing it). In particular, the main instrument (normally a flute, corresponding to the minstrel\'s words) goes through several identity crises in a row before deciding it wants to be a piano.

I\'m attaching a recording of the problem, as well as one from DOSBox for reference.

Note that the problem affects both AdLib emulators offered by ScummVM (\"DOSBox\" and \"MAME\"), and that it is perfectly reproducible even if the intro is left to play out without clicking or interrupting it in any way. The MT-32 emulator is not affected.

Ticket imported from: #3489099. Ticket imported from: bugs/5982.

Attachments (2)

scummvm.ogg (245.9 KB ) - added by SF/kurufinwe 8 years ago.
Recording of the problem
dosbox.ogg (249.7 KB ) - added by SF/kurufinwe 8 years ago.
Recording from DOSBox (correct)

Download all attachments as: .zip

Change History (5)

by SF/kurufinwe, 8 years ago

Attachment: scummvm.ogg added

Recording of the problem

by SF/kurufinwe, 8 years ago

Attachment: dosbox.ogg added

Recording from DOSBox (correct)

comment:1 by bluegr, 7 years ago

This is song 104.

The problem seems to be caused by MidiDriver_AdLib::findVoiceBasic(), inside the adlib driver - it keeps shuffling the free channels

comment:2 by wjp, 6 years ago

This is potentially fixed by my work-in-progress sci_remap branch. At least I don't hear the issue on that branch anymore.

comment:3 by wjp, 6 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.