Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5972 closed defect (fixed)

BASS: Save game corruption on Android (and other platforms?)

Reported by: SF/timsmith0 Owned by: wjp
Priority: blocker Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

ScummVM Version: 1.4.0 (Android) , 1.4.1 (Android) & 1.4.1 (Windows)

Bug Details: When I try to load any save file (have tried different ones at different time points) for BASS it shows the Virgin logo with some scene audio (changes depending on where save was made within the game) and then closes with no exception report. This behavior happens on both Android and Windows (Both 'Crash' out to their respective desktops). This ticket is only in regards to the Android problem but for fault finding purposes I tried this on a Windows PC to see if the error was isolated to Android and it appears that it isn't.

Language of Game: English

Version: Talkie CD version from http://www.scummvm.org/downloads

Platform: Android Honeycomb 3.2.1 on HTC Flyer (with HTC Sense 1.1 for Tablet) also tried on Windows Vista Home Premium 32 bit.

Ticket imported from: #3487117. Ticket imported from: bugs/5972.

Attachments (8)

SKY-VM.000 (14.1 KB) - added by SF/timsmith0 7 years ago.
SKY-VM.001 (12.4 KB) - added by SF/timsmith0 7 years ago.
SKY-VM.SAV (50 bytes) - added by SF/timsmith0 7 years ago.
SKY-VM.002 (12.4 KB) - added by SF/timsmith0 7 years ago.
F5 Save Method
SKY-VM.003 (12.4 KB) - added by SF/timsmith0 7 years ago.
CTRL+F5 save Method
ft.s00 (17.9 KB) - added by SF/timsmith0 7 years ago.
FT Save .s00 Game File
SKY-VM.2.002 (12.4 KB) - added by SF/timsmith0 7 years ago.
Save File after skipping intro
sky_repaired.000 (14.2 KB) - added by wjp 7 years ago.
hopefully repaired version of SKY-VM.000

Download all attachments as: .zip

Change History (22)

Changed 7 years ago by SF/timsmith0

Attachment: SKY-VM.000 added

Changed 7 years ago by SF/timsmith0

Attachment: SKY-VM.001 added

Changed 7 years ago by SF/timsmith0

Attachment: SKY-VM.SAV added

comment:1 Changed 7 years ago by wjp

Thank you very much for this. We had had multiple reports of savegame trouble with BASS on Android, but nobody had managed to supply a broken savegame yet for debugging.

It seems the mouse cursor stored in these saves is invalid. I'm not yet sure of the cause for this, but it seems as if the code saving the mouse cursor (from the _skyMouse object to the _savedMouse variable) is missing when using the GMM instead of the main control panel. I don't yet see how to reproduce the problem, though, since _savedMouse is apparently usually set in other ways when entering the game. But regardless, this seems wrong.

comment:2 Changed 7 years ago by wjp

Summary: Unable to load save games on AndroidBASS: Unable to load save games on Android

comment:3 Changed 7 years ago by wjp

To help with debugging, could you describe as exactly as possible how you created the savegames you attached?

Specifically:
On Android or on Windows?
How did you start BASS in ScummVM in the session in which you saved? (Going through the ScummVM launcher? Loading a different game from the ScummVM launcher directly? Starting BASS regularly, and then loading a save from within BASS?)
How did you save? (Using the in-game F5 menu? The scummvm menu behind ctrl-f5? Autosave?)

(I'm using windows-specific keys here, because I don't know the equivalents on Android, but since you have run scummvm on both android and windows, I hope you understand what I mean.)

comment:4 Changed 7 years ago by SF/timsmith0

That's fine no problem. There is a lot of information so I will try to lay it out as clear as I can to help with the replication of the error.

The 1st save was created in version 1.4.0 from the Android Market
The 2nd save was created in version 1.4.1 obtained from the ScummVM Download page.

I did this to check if it was a version dependent problem/issue. Both contained the same error when saving on an Android Device.

The saves were created via the ScummVM type menu which appears when you press the Android menu button (same menu that appears when using CTRL+F5 on Windows).

I have since tried again on the Windows system (using ScummVM 1.4.1 exe file from the Download page and when using either F5 (Native Game Menu) or CTRL+F5 (ScummVM Menu) the error does not replicate itself

These saves work fine and are now attached SKY-VM.002 is F5 method and SKY-VM.003 is CTRL+F5 method

I have tried loading the saves via the ScummVM launcher and from both menus within the game (Native and ScummVM) but the same force close happens (Windows only).

Within Android there is only one in game menu but the same force crash happens from ScummVM launcher and in game ScummVM menu (No access to native in game menu)

Hope this is clear as I am typing as I check each point.

Changed 7 years ago by SF/timsmith0

Attachment: SKY-VM.002 added

F5 Save Method

Changed 7 years ago by SF/timsmith0

Attachment: SKY-VM.003 added

CTRL+F5 save Method

comment:5 Changed 7 years ago by SF/timsmith0

So it appears that the error is isolated to the way the Android Platform saves the files for BASS. I have tried on another Game (Full Throttle). I have attached this file as well just for you to have a look and see if the mouse is saved differently on FT compared to BASS.

Changed 7 years ago by SF/timsmith0

Attachment: ft.s00 added

FT Save .s00 Game File

comment:6 Changed 7 years ago by wjp

Thank you for extra the information. We think we have tracked it down to the combination of watching the entire intro without interrupting it with escape, and then using the ctrl-f5 menu to save without ever having opened the f5 menu.

We're still working on a solution, but as a workaround skipping the intro should work.

comment:7 Changed 7 years ago by wjp

Priority: normalblocker
Summary: BASS: Unable to load save games on AndroidBASS: Save game corruption on Android (and other platforms?)

comment:8 Changed 7 years ago by SF/timsmith0

So I guess my save data won't work now?

Oh and just for your information if needed in future with it being Android there is no escape button so I have tried some options and found it to be the back button (on Honeycomb at least) still no way of accessing the native Game Menu.

Just checked and yes with skipping the intro saving via the ScummVM menu works when loading the save. Another save file SKY-VM.002 (Description added to help identify it) is attached to give you a comparison file.

Changed 7 years ago by SF/timsmith0

Attachment: SKY-VM.2.002 added

Save File after skipping intro

comment:9 Changed 7 years ago by SF/timsmith0

Let me know if there is anything you would like me to test

Changed 7 years ago by wjp

Attachment: sky_repaired.000 added

hopefully repaired version of SKY-VM.000

comment:10 Changed 7 years ago by wjp

I've replaced the corrupt values in SKY-VM.000, and attached it as sky_repaired.000. (You'll have to rename it back for it to work.) You may get slight font or mouse glitches after loading, but they should be only temporary.

comment:11 Changed 7 years ago by SF/timsmith0

That's great Thank You for taking the time to do that it now works. I hope the information I have provided has been useful.

Again if any testing for Windows (Vista & 7), Mac (Lion) or Android on HTC (Gingerbread (phone) & Honeycomb (tablet)) is needed and I have the game I'm happy to try recreate any problems for you. I'm a 1st year Games Development Student myself and I know how sometimes testing on a specific platform is needed but hard to do if the equipment is not available.

comment:12 Changed 7 years ago by wjp

Good to hear, and thanks for the assistance. We'll get back in touch for testing if we have a fix available for the problem.

comment:13 Changed 7 years ago by wjp

This should be fixed now in git by revision 87e85e17cbe.

comment:14 Changed 7 years ago by wjp

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.