Opened 8 years ago

Closed 4 years ago

Last modified 11 months ago

#5962 closed defect (fixed)

ANDROID: Texture corruption when not in full-screen

Reported by: (none) Owned by: fuzzie
Priority: high Component: Port: Android
Keywords: Cc:
Game:

Description

More details here: http://forums.scummvm.org/viewtopic.php?t=11158
[Appears to affect at least two Xperia model phones - *possibly* an issue with Adreno GPUs...?]

When playing with 4:3 aspect ratio the aspect ratio of the game is displayed correctly, and games play fine. However (instead of black borders to the left and right of the game) there's a yellow blinking bar on the left hand side of the screen and duplication of some of the gaming window on the right. When paused the yellow bar and duplication disappear but come back when unpaused. This occurs on any game (on market version 1.4.0 or latest daily build as of 3rd Feb. 2012).

Ticket imported from: #3483983. Ticket imported from: bugs/5962.

Change History (17)

comment:1 by fuzzie, 8 years ago

This is currently dealt with by the "htc_fail" variable, which apparently needs expanding to cover more than just HTC.

comment:2 by fuzzie, 8 years ago

Owner: set to fuzzie

comment:3 by (none), 8 years ago

I can confirm the same issue on the Sony Ericsson Xperia Play (R800a) on ScummVM 1.4.0, market downloaded. Phone firmware is 2.3.4 and here is a screen capture: http://i.imgur.com/aXIit.png

comment:4 by (none), 8 years ago

same on samsung galaxy s1 plus; scummvm 1.4.0; firmware 2.3.3 & 2.3.6

comment:5 by (none), 8 years ago

if "fullscreen mode" is checked "aspect ratio correction" has no effect. if not yellow blinking and duplication like in your description. is fullscreen option required? would suggest to remove it. your work is very much appreciated btw :)

comment:6 by fuzzie, 8 years ago

Summary: ANDROID: Aspect ratio issuesANDROID: Texture corruption when not in full-screen

comment:7 by sev-, 7 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:8 by sev-, 7 years ago

Priority: normalhigh

comment:9 by SF/petro314, 7 years ago

This Issue is reproducable with a Nexus 4 running Android 4.2.1 using ScummVM 1.6.0git2477-g41725ab (Jan 11 2013 04:18:26). Issue appears with both comi and sword1 engines.

comment:10 by fuzzie, 6 years ago

Bleh. This is happening on a lot more hardware, and there's a new release happening soon, so I think we're just going to have to enable the htcfail workaround on all devices for now, and worry about using the appropriate EGL calls at a later point.

comment:11 by SF/rnq, 6 years ago

This issue still exists on the latest nightly (2013-05-06) on a LG Nexus 4. I notice texture corruption changing when I touch the screen. When I put ScummVM to background and bring it back texture corruption gets worse and it's not changing with touch input anymore.

comment:12 by SF/nazo, 6 years ago

I've been running into this too. Both my Samsung Galaxy S3 and Nexus 7 do it. I wonder if it isn't a buffer thing or something though? It seems to be flickering between some sort of corruption of whatever was in the area where the borders are previously. One thing that I tried on a whim which makes it seem like it goes away is to turn off the screen for just a moment then back on. Well, my lockscreen's background is black, so this may not work for anyone with a wallpaper I suppose, but presuming it is still flickering it's now flickering from black to black. It's a lot less irritating that way at least.

Honestly, I kind of feel like this particular issue is kind of dangerous. I think it could actually induce seizures in those who are susceptible to such things. It irritates me in such a way that I almost wonder if it could cause seizures among those who aren't susceptible even.

comment:13 by fuzzie, 6 years ago

This should be fixed in the next daily builds by forcing the htcfail workaround on all devices.

comment:14 by fuzzie, 6 years ago

Resolution: fixed
Status: newpending

comment:15 by Strangerke, 6 years ago

Component: --Unset--Ports

comment:16 by sev-, 4 years ago

Status: pendingclosed

comment:17 by digitall, 11 months ago

Component: PortsPort: Android
Note: See TracTickets for help on using tickets.