Opened 8 years ago

Closed 2 years ago

#5951 closed defect (wontfix)

ANDROID: Can't reach topmost border in BASS on Galaxy S2

Reported by: SF/hexaae Owned by: dafioram
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

On Android Samsung Galaxy S2, Beneath A Steel Sky is simply unplayable because I can't touch the topmost area to activate the pull-down menu! :( It's unreachable by the touch screen sensors.

Please, can someone fix the 'sky' plugin for Android adding an option to shift the screen at least 20 pixels down and make the upper area reachable by the touch sensors?

http://s14.postimage.org/40dayfo8h/SC20111217_195242.png http://s14.postimage.org/wra4ohu29/SC20111217_195249.png

Ticket imported from: #3480936. Ticket imported from: bugs/5951.

Change History (11)

comment:1 by SF/hexaae, 8 years ago

Summary: BASS: Can't reach topmost border on Android Galaxy S2ANDROID: Can't reach topmost border in BASS on Galaxy S2

comment:2 by SF/mihaiz, 8 years ago

I'll take a look at it.

comment:3 by SF/mihaiz, 8 years ago

I wasn't able to reproduce the bug. I'll try to make the engine send a warning if the game's height would be bigger than the screen's.

comment:4 by SF/hexaae, 8 years ago

The problem is not the screen's height. It's not cropped. It's simply positioned to high: my device touchscreen sensor can't reach that part of the screen as you can see from the pics I've posted. The cursor can't reach the top part of the screen. Maybe the touchscreen sensitivity varies with different devices and for me the problem is that I can't "touch high enough to make the pop-down menu visible".... That's why I've asked if someone could add a workaround option to shift the screen position down a few pixels (10-20?)...

comment:5 by SF/hexaae, 7 years ago

Bug still present in current V1.5 on Google Play... :( Now I have an HTC One S and have the same issue: topmost bar is unreachable with touchscreen controls...

comment:6 by digitall, 7 years ago

Owner: set to fuzzie

comment:7 by digitall, 7 years ago

This bug has been reported again on Galaxy S2 and HTC One S by hexaae as bug #3575567: https://sourceforge.net/tracker/index.php?func=detail&aid=3575567&group_id=37116&atid=418820 Closed that bug as a duplicate.

hexaae:It would be useful if you could manage to get the relevant logs during BASS loading and play to help determine what is happening: https://developer.android.com/tools/help/adb.html#logcat and attach them to this bug as a zipped text file.

comment:8 by digitall, 7 years ago

hexaae: Have just checked with the Android team.

This is a known problem with the Touchscreen Touchpad input mode, but BASS works fine with the default Touchscreen direct mode, so this does not render BASS unplayable. Please see the following for information on how to change modes: http://wiki.scummvm.org/index.php/Android#Touchscreen

The forum thread for this also contains some further notes on the status of this: http://forums.scummvm.org/viewtopic.php?t=11229 including the comment: "(Didn't this get discussed before?) This isn't going to get fixed in the 1.4.x series because it's non-trivial to do and it works fine with the default input configuration. It is on my TODO for 1.5.0,..."

Unfortunately other more critical issues and Real Life meant that this was not incorporated to v1.5.0.

comment:9 by SF/hexaae, 7 years ago

Thank you. Oh! Always wondered why the first time I've installed ScummVM on my 2 Android smartphones the mouse was in direct mode and then suddenly changed! :)

As wiki says:

The touchscreen can be used in two modes 1) Direct mode 2) Touchpad mode When in direct mode, the mouse cursor moves to the touched point on screen. In touchpad mode, the mouse cursor is independent of the touched point, it is moved relative to its current position - like on a touchpad.

The port currently misses its own configuration dialog, the mode can be toggled with the "Mixed AdLib/MIDI mode" on the MIDI tab in ScummVM's own option dialog.

...So I have to switch on the Mixed AdbLib/MIDI mode (???) to use the direct mode. Thank you.

Hope for a proper solution in the next version! :)

comment:10 by digitall, 7 years ago

hexaae: Yes, this was a development hack as the ScummVM GUI lacks a sensible place to add options related to the backend, so the Mixed AdLib/MIDI mode checkbox also toggles the Android Input Mode.

fuzzie: Can we look at moving this to the Options Dialog -> Misc panel as a new checkbox... as it doesn't look like we will add the backend Options any time soon and this is really confusing for users?

comment:11 by dafioram, 2 years ago

Owner: changed from fuzzie to dafioram
Resolution: wontfix
Status: newclosed

ScummVM: Android-arm ed638bac (11/27/2017)
Device: Tablet Tf201
OS: Android 4.1.1

It is a slight challenge on my device to access the top menu using direct mode. There is no challenge at all if I use touchpad mode.

It would be an improvement to have the android touch mode be a separate checkbox from the midi option, but this issue is not about that and it is noted in the wiki.

Note: See TracTickets for help on using tickets.