Opened 8 years ago

Closed 8 years ago

#5915 closed defect (fixed)

Ringworld spanish version crash at the intro

Reported by: SF/nerdknight Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Ringworld: Revenge of the Patriarch

Description

Game: Ringworld: Revenge of the Patriarch, spanish version
ScummVM version: 1.4.0
Platforms: all

While playing the intro, ScummVM crashes with the following output:

scummvm: engines/tsage/graphics.cpp:1384: int TsAGE::GfxFont::writeChar(char): La declaración «(_fontData != __null) && ((uint8)ch < _numChars)» no se cumple.
Abortado

I think the problem is triggered when the engine tries to draw spanish characters.
I hacked throw the code and replaced the assert with an if, so when that condition is not meet, it does nothing, the result was the game didn't crash any more, but the spanish special characters (á, é, í, ó, ú,ñ, etc) where missing.

Ticket imported from: #3450779. Ticket imported from: bugs/5915.

Change History (3)

comment:1 by SF/nerdknight, 8 years ago

Summary: Rinworld spanish version crash at the introRingworld spanish version crash at the intro

comment:2 by dreammaster, 8 years ago

Owner: set to dreammaster

comment:3 by dreammaster, 8 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.