Opened 8 years ago

Last modified 12 months ago

#5897 new defect

Symbian: KQ6 windows won't start

Reported by: SF/mataku Owned by: anotherguest
Priority: normal Component: Port: Symbian
Keywords: Cc:
Game: King's Quest 6

Description

using 1.3.0 (may 25 build) on s60v5

when trying to start KQ6 CD windows version (english) I get the error "could not switch to resolution: '640x440', then i click okay and i scummvm closes down.

Ticket imported from: #3437042. Ticket imported from: bugs/5897.

Change History (8)

comment:1 by bluegr, 8 years ago

After a discussion on IRC, we agreed that this case should be handled at the backend level. Assigning this to anotherguest.

comment:2 by bluegr, 8 years ago

Owner: set to anotherguest

comment:3 by fuzzie, 8 years ago

It was later pointed out on IRC that the most likely cause is that your s60v5 device simply doesn't have a display with high enough resolution to play the game, since most of the devices seem to only offer 640x360.

comment:4 by SF/mataku, 8 years ago

just to comment on that, on one of the earlier SVNs (around 1.0 era, right when this game was starting to get supported) this version worked fine on my phone, it just stretched the resolution accordingly. Also, games that require 640x480 such as discworld 2 and CMI work fine and don't have such an issue (at least the last time i checked)

comment:5 by digitall, 8 years ago

mataku: Could you please try to locate the specific SVN version which worked or at least a tighter timeframe?
If you could also test earlier release versions back to v1.2.0 or earlier, to see if this is a recent regression?

SCI Developers: This message is emitted from within the Graphics initialisation helper function (void initGraphics(int width, int height, bool defaultTo1xScaler, const Graphics::PixelFormat *format) in engines/engine.cpp), but it may be due to a change in the backend return values from endGFXTransaction() or due to default1xScalar ?

comment:6 by SF/mataku, 8 years ago

well i've complained about it in the forum when it first appeared, so the build before that one worked (Aug 06, 2010):
http://forums.scummvm.org/viewtopic.php?p=60269#60269

comment:7 by digitall, 8 years ago

mataku: That is a very long time back, prior to GSOC 2010 OpenGL graphics changes and a huge number of changes to SCI engine... and SymbianOS builds were made infrequently so I can't really locate this any closer than between around 2010-08-06 and 2010-05-09without a working SymbianOS build toolchain and test device, so anotherguest will have to look at this.

anotherguest: This may be in the SCI engine, since the SCI engine has more than one location with an initGraphics(int width, int height, bool defaultTo1xScaler, const Graphics::PixelFormat *format) call.. Might be helpful to replicate and then add debug output to locate which call is the problem here...

comment:8 by digitall, 12 months ago

Component: Engine: SCIPort: Symbian
Note: See TracTickets for help on using tickets.