Opened 8 years ago

Closed 8 years ago

#5889 closed defect (fixed)

LOL-CD: Bug in the White Tower with "Face your greed" riddle

Reported by: SF/josemuk Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Lands of Lore

Description

Windows 7 32bit Latest daily build: 1.4.0pre27-g29dd6df

According to this solution:

"Step forward a few times and you will hear a piercing scream! The niche in the wall is empty. Around the corner is a sign that says "Face your greed". Along the floor you will see various items move around a pillar as if on a moving conveyer belt on the floor. Around the pillar are four empty niches. The items are a wand of death, a Dwarvish horseshoe, a Dwarvish Helm and a sabre 'cougar'."

There should be only four objects but I can see five: the ones listed above plus a poison dart sword that can't be equipped.

Check the attached savegame.

Ticket imported from: #3429455. Ticket imported from: bugs/5889.

Attachments (1)

lol-cd.000 (26.6 KB ) - added by SF/josemuk 8 years ago.
Lands of Lore CD - White Tower Savegame

Download all attachments as: .zip

Change History (10)

by SF/josemuk, 8 years ago

Attachment: lol-cd.000 added

Lands of Lore CD - White Tower Savegame

comment:1 by lordhoto, 8 years ago

Owner: set to athrxx

comment:2 by athrxx, 8 years ago

Now you simply put all all those items EXCEPT the poison dart into the niches and you should be fine. There is no bug there.

comment:3 by SF/josemuk, 8 years ago

Did the original game work that way? (I mean, was the poison dart there?) Because to me that didn't make sense and I couldn't solve the riddle until I saw the listed objects.

comment:4 by athrxx, 8 years ago

I am not sure about the behaviour in DosBox since I don't have a savegame close to that area and I really don't want to fight those wraiths on the top floor again. I'll investigate this some more. Maybe this is some (strange) bug after all.

comment:5 by bluegr, 8 years ago

Here's a lets play video from that part: www.youtube.com/watch?v=IZuOtZcRPaI#t=7m

comment:6 by SF/josemuk, 8 years ago

And here is another one:

http://www.youtube.com/watch?v=DKdBs7Pc1JE#t=9298s

Both videos only show four objects.

comment:7 by athrxx, 8 years ago

The problem is that the script definitely creates and places not only those 4 items, but also that posion dart. Script behavior is kind of weird there. I havent't found the bug yet.

comment:8 by athrxx, 8 years ago

Resolution: fixed
Status: newclosed

comment:9 by athrxx, 8 years ago

I have fixed that issue now. The poison dart will no longer appear if you load a savegame before entering the basement for the first time. If you load a savegame where the dart has already been created it will stay, though (the item creation process only takes place when entering for the first time).

The fix will most likely not make it into the 1.4.0 release, since the source code for that release is alreay "frozen".

Note: See TracTickets for help on using tickets.