Opened 9 years ago

Closed 9 years ago

#5875 closed defect (fixed)

TSAGE: Ringworld - Crash When Saving

Reported by: SF/vengarato Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Ringworld: Revenge of the Patriarch

Description

ScummVM 1.4.0git2717-g3e9e237 (Oct 12 2011 22:57:36)

restart game & in first playable scene save the game & it gives the following error: >User picked target 'ringworld' (gameid 'tsage')... > Looking for a plugin supporting this gameid... TsAGE > Starting 'Tsunami TsAGE-based Game' >Assertion failed: in || out, file ./common/serializer.h, line 81 >This application has requested the Runtime to terminate it in an unusual way. >Please contact the application's support team for more information.

English Win32 (Win7, Intel 2.8GHz, 2G ram)

Ticket imported from: #3422624. Ticket imported from: bugs/5875.

Change History (8)

comment:1 by digitall, 9 years ago

Summary: Crashes when savedTSAGE: Ringworld - Crash When Saving

comment:2 by digitall, 9 years ago

vengarato: I can replicate this on Linux x86_32 with my latest development build. TSAGE is still under active development. There were a number of corrections last night which will only be included in the next daily build, please can you test this new build and report if the issue is corrected for you?: http://buildbot.scummvm.org/builds.html

If it is not, please can you also try Kirben's win32 daily snapshot builds to confirm if this may be a library issue?: http://www.scummvm.org/downloads/#daily

comment:3 by digitall, 9 years ago

Apologies, I can _NOT_ replicate this on Linux x86_32 with my latest development build, hence my desire to have you check the latest build to see if this has been fixed.

comment:4 by SF/vengarato, 9 years ago

tdhs: using the latest win32 dev build listed at the link you gave me (http://buildbot.scummvm.org/builds.html) AND Kirbin's daily snapshot, I duplicated the bug, same error msg & all. Seems to happen whenever I try to save, even at the opening credits. I'm wondering if my game files could be corrupt??

comment:5 by digitall, 9 years ago

vengarato: That is possible. Please can you attach a text file to this bug containing a file listing of your Ringworld data files with MD5sum checksums. The output of a tool such as http://md5summer.org/ would be optimal. This will allow us to check your datafiles. If you could also indicate what variant of Ringworld you have i.e. CD, Floppy etc. and any publisher version marking from the CD/Floppy.

comment:6 by dreammaster, 9 years ago

Okay, I've been able to replicate the problem when trying to save to an invalid path - in my case I tried setting save path to a CD (which is of course read only), and it bailed out. The engine currently doesn't gracefully handle such cases. I'll add in an explicit error dialog in such cases.

comment:7 by dreammaster, 9 years ago

Owner: set to dreammaster

comment:8 by dreammaster, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.