Opened 9 years ago

Closed 9 years ago

#5874 closed defect (fixed)

DW2: US version uses UK graphics

Reported by: eriktorbjorn Owned by: eriktorbjorn
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld II

Description

US "Mortality Bytes" version of the game Current ScummVM git snapshot

This was already mentioned in bug #2772743 ("DW2: Unsupported US version?"), but rather than reopening that one (which was mainly about having to rename files in the US version to get it to run), I'm filing a new bug report.

When running the US version in DOSBox, it shows a "Mortality Bytes" title screen and shows a US flag in the settings dialog. When running it in ScummVM, it shows the same "Missing Presumed..." title screen and UK flag as the UK version. I'll attach some DOSBox screenshots to show what I mean.

Ticket imported from: #3422433. Ticket imported from: bugs/5874.

Attachments (2)

dw2-main.png (59.9 KB ) - added by eriktorbjorn 9 years ago.
Title screen (DOSBox)
dw2-options.png (37.5 KB ) - added by eriktorbjorn 9 years ago.
Options dialog (DOSBox)

Download all attachments as: .zip

Change History (9)

by eriktorbjorn, 9 years ago

Attachment: dw2-main.png added

Title screen (DOSBox)

by eriktorbjorn, 9 years ago

Attachment: dw2-options.png added

Options dialog (DOSBox)

comment:1 by eriktorbjorn, 9 years ago

It looks like both of these can be fixed by making sure that _language is set to TXT_US instead of TXT_ENGLISH if the language is Common::EN_USA in Config::readFromDisk(). I'm not quite confident enough about that to make that change without at least discussing it with someone first.

comment:2 by eriktorbjorn, 9 years ago

A similar change may have to be made to Config::writeToDisk() as well, I guess.

comment:3 by dreammaster, 9 years ago

I don't have the US version to test with, but it seems like only the two methods you list below would need to be changed. I'd suggest that if no one else with the US version comes forward to try making the change, you go ahead and do it, and commit it if it works.

comment:4 by eriktorbjorn, 9 years ago

Owner: set to eriktorbjorn
Resolution: fixed

comment:5 by eriktorbjorn, 9 years ago

Thanks. I've made the change, and added a note to the NEWS file. Hopefully I'll be able to play through the game before the 1.4.0 release, but right now there's an annoying regression from commit d5690e0. (See note on GitHub for details, though you should already have received an automated mail about it.)

comment:6 by digitall, 9 years ago

eriktorbjorn: Regression fixed by dreammaster in 6811a3daffc2743d2d733050be9306dcbf419214. Closing this.

comment:7 by digitall, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.