Opened 9 years ago

Closed 9 years ago

#5872 closed defect (fixed)

Can't pick up straw in palace

Reported by: SF/vorph999 Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Keywords: script Cc:
Game: Ringworld: Revenge of the Patriarch

Description

After entering the palace Quinn is taken to the slave overseer. In this room I am supposed to pick up some dry staw (I need it later, to set fire to the patriarchs bed) When I try to take the straw, the game tells me "You have all the straw that you need", even though I don't have any...

Savegame attached

ScummVM Version: 1.4.0git2710-g174b8d6 OS: Windows XP SP3 x86 Game Version: Ringworld: Revenge of Patriarch Floppy/DOS/English

Ticket imported from: #3422141. Ticket imported from: bugs/5872.

Attachments (1)

ringworld.004 (23.3 KB ) - added by SF/vorph999 9 years ago.
Savegame

Download all attachments as: .zip

Change History (4)

by SF/vorph999, 9 years ago

Attachment: ringworld.004 added

Savegame

comment:1 by dreammaster, 9 years ago

Owner: set to dreammaster

comment:2 by dreammaster, 9 years ago

Another problem caused by the special handling in the NamedHotspot class to handle Blue Force changes. I've spearated the class into separate classes entirely for both Ringworld and Blue Force, so hopefully there should be no further problems caused by it.

comment:3 by dreammaster, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.