Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5871 closed defect (fixed)

Can´t advance to palace

Reported by: SF/truus999 Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Keywords: script Cc:
Game: Ringworld: Revenge of the Patriarch

Description

At the beginning of the "Quest" at the Slave People World, I need to talk to the slave by the sea to get some rugged clothes as disguise. Whenever I try to talk to him I get the message "You receive no response". What seems strange to me, is that during the conversation between the Seeker and Quinn the Animation of the Slave stopped. When the Seeker leaves the Scene the guy still seems to be frozen. He only starts to move again when I leave an re-enter the location.

This is for the cd version. Vorph had the same problem with the floppy version

Scummvm 1.4.0git2604-g19cac9b Game CD DOS English WIN7 64 bits

NB± I have completed the game before )floppy version' just after it was supported without any problems so this is a regression

Ticket imported from: #3421921. Ticket imported from: bugs/5871.

Attachments (1)

ringworld-cd.014 (23.5 KB ) - added by SF/truus999 9 years ago.
Save game

Download all attachments as: .zip

Change History (4)

by SF/truus999, 9 years ago

Attachment: ringworld-cd.014 added

Save game

comment:1 by dreammaster, 9 years ago

Thanks for reporting the problem. It was a regression in one of the hotspot classes that changed in Blue Force. Despite my efforts to wrap everything with special game version checks, in this case the hotspot class was suppressing the custom action for the hotspot in this scene.

comment:2 by dreammaster, 9 years ago

Resolution: fixed
Status: newclosed

comment:3 by dreammaster, 9 years ago

Owner: set to dreammaster
Note: See TracTickets for help on using tickets.