Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5868 closed defect (duplicate)

KQ6 - Freezing when picking up nightingale's letter

Reported by: SF/yfrwlf Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

After picking up the letter and the speech is finished, the mouse cursor will stay a crown and the nightingale will still fly around but you'll be stuck and unable to move. Also, if you get too close to the snapdragons, you will freeze there and be unable to move as well. Probably a related bug.

Ticket imported from: #3421098. Ticket imported from: bugs/5868.

Attachments (1)

kq6-cd-win.018 (46.3 KB ) - added by SF/yfrwlf 9 years ago.
Messed Up Game

Download all attachments as: .zip

Change History (9)

comment:1 by SF/yfrwlf, 9 years ago

I'm using Scumm 1.3.1. For KQ6, it says KQ6 version 1.000.00G, and this is the CD DOS version.

comment:2 by SF/yfrwlf, 9 years ago

I tried this bug several times and I'd have the problem each time, but after creating a new game and doing the nightingale part ASAP, it no longer was freezing up at either of the parts mentioned in my bug report. It still happens in my old save game though. What a strange intermittent bug...

comment:3 by SF/yfrwlf, 9 years ago

Perhaps this bug only shows up when you complete game objectives in a particular order?

comment:4 by bluegr, 9 years ago

Please attach saved games in the places where these lockups occur

comment:5 by SF/yfrwlf, 9 years ago

One of these warnings may be the cause:

[2011-09-11 03:07:24] ScummVM 1.3.1 (Aug 5 2011 17:27:55) [2011-09-11 03:07:24] Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth [2011-09-11 03:07:24] --- Log opened. [2011-09-11 03:07:24] WARNING: You are missing the 'translations.dat' file. GUI translation will not be available! [2011-09-11 03:07:27] WARNING: SearchSet::add: archive '/home/yfrwlf/Scumm' already present! [2011-09-11 03:07:31] WARNING: Unhandled SCI kShowMovie subop 6! [2011-09-11 03:07:47] WARNING: kDoSound(play): Slot not found (0001:1ec5)! [2011-09-11 03:08:23] --- Log closed successfully.

by SF/yfrwlf, 9 years ago

Attachment: kq6-cd-win.018 added

Messed Up Game

comment:6 by SF/yfrwlf, 9 years ago

The attached game save is where the letter is on the ground waiting to be picked up. After picking it up, you'll be unable to move.

comment:7 by bluegr, 9 years ago

This is the same problem as in bug #3413301. It has been fixed in the daily versions, and will be included in the next stable ScummVM 1.4.0 release. Please, download a daily version from: http://buildbot.scummvm.org/builds.html

Closing as duplicate

comment:8 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.