Opened 8 years ago

Last modified 8 years ago

#5861 new defect

DINGUX: LOL - Random Slowdowns Fighting Enemies

Reported by: SF/tystarla Owned by: hkzlab
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Lands of Lore

Description

A slowdown occurs randomly only on ennemies and fight scripts (weapon+magic), although the global speed of the game is not affected

A global slowdown is also noticeable in Opin wood and Uper Opin wood

Ticket imported from: #3419612. Ticket imported from: bugs/5861.

Attachments (1)

lol_saves.zip (108.6 KB ) - added by digitall 8 years ago.
LOL Savegames For Replication

Download all attachments as: .zip

Change History (13)

comment:1 by digitall, 8 years ago

Summary: DINGUX : slowdownDINGUX: LOL - Random Slowdowns Fighting Enemies

comment:2 by digitall, 8 years ago

tystaria: Thank you for your bug report. Could you please do the following to advance investigation of this bug:
1. Please give full detail of your Dingux device and Dingux OS ROM version (A320?).
2. Pleae give full detail of the version of ScummVM you are testing. I assume since LoL is not present in the current stable version, then you must be testing a v1.4.0pre daily build. The version can be found on the Launcher screen below the Logo.
3. Please attach savegames to allow easy demonstration of this issue i.e. just before fight, in Opin Wood and Uper Opin Wood.
4. Please try to replicate this issue on a desktop version of the daily build i.e. Linux, Win32 or MacOSX so we can determine if this is an issue with the DINGUX platform backend or a problem with the Kyra LoL engine.

Thanks.

comment:3 by SF/tystarla, 8 years ago

I'm using an A320 with an alfa version of opendingux and the scummVM daily build v1.4.0

The game runs just fine with ScummVM on Win32. I will try again with another dingux kernel and see if the problem still remains.

I will post a valid savegame as soon as possible.

comment:4 by digitall, 8 years ago

Owner: set to hkzlab

comment:5 by digitall, 8 years ago

tystaria: Thanks. This looks like an issue specifc to Dingux then, assigning to the Dingux maintainer.

Just to be clear, can you be clear about:
1. Which daily build you are using i.e. is it the current daily development build from: http://buildbot.scummvm.org/builds.html
2. Which alpha pre-release version of the OpenDingux Kernel/Firmware you are using and where is it from? i.e.
http://www.treewalker.org/opendingux/ or some location at http://dingoowiki.com/index.php?title=Main_Page

hkz: Might be a good idea to add some notes to http://wiki.scummvm.org/index.php/Dingux indicating which versions of the Dingoo / Dingux / OpenDingux kernel/firmware are supported/tested targets for our builds...

comment:6 by hkzlab, 8 years ago

This will be an hard one to "debug" since I don't own the game.
Also, checking this one on Win32 isn't really discrimination on where the problem lies: dingoo has a rather slow cpu compared to modern PCs... I'll have a look on a slow machine (like a PS2) when i can get hold of a copy.

As for the notes, good idea. I'll look into it when I have some time, since the version of OpenDingux i use is rather old and the port requires retesting on newer ones.

comment:7 by digitall, 8 years ago

hkz: I do have the game, so if the submitter attaches savegames, I can take a look at the relevant locations and try to work out what is different about that point in the game that might be causing this i.e. SFX, MIDI etc.
Though looking on Ebay, this game is not rare since it was released on White Label and there are 30+ copies listed at not outrageous price i.e. 20-30 GBP, so could grab a copy :-)

comment:8 by SF/tystarla, 8 years ago

I use the rootfs file with fixed lib, posted on this topic :
http://forums.scummvm.org/viewtopic.php?t=9192
the direct link is :
http://hkzlab.ipv7.net/files/misc/dingux/opendingux/opendingux_kernel_rootfs.zip

Since I've notice no bug while testing this kernel with plenty of scummvm games, I guess that the bug I saw is not caused by this.

the scummvm daily buid is : 1.4.0git1662-gdd0ad3c (Aug 19 2011 05:33:16)

I'm trying to reproduce the bug but since I do not understand the mecanism of it, I 'm not able to show to you. I guess this occurs randomly.

comment:9 by SF/tystarla, 8 years ago

Here is my savegame :
https://rapidshare.com/files/455679589/lol_saves.zip

The bug won't appears every time. like I said, I don't understand the mechanism to make it come.

by digitall, 8 years ago

Attachment: lol_saves.zip added

LOL Savegames For Replication

comment:10 by digitall, 8 years ago

tsytarla: Thanks for the savegames.

Just a note, you can attach file attachments up to 256K per item to a sourceforge bug, so in the future please can you attach savegames directly as I have now done.

External services are not recommended as bugs can be open for a while and when the developer comes to look at them, the external link is dead. (Note, we do occasionally use external services for files > 256K limit i.e. large debug traces, but these should be the exception).

comment:11 by hkzlab, 8 years ago

I see that the savegames are from a CD version. Did you simply copy all the files off the cd and into the Dingoo SD card or did you do something else, like compressing game data first?

comment:12 by SF/tystarla, 8 years ago

Game datas were just taken from a compressed ISO file to the SD card.
Only required files were put on the card.

Note: See TracTickets for help on using tickets.