Opened 8 years ago

Closed 22 months ago

#5838 closed defect (fixed)

TUCKER: Bud allowed to walk outside walkable area when visiting the club

Reported by: SF/async2 Owned by: bonki
Priority: normal Component: Engine: Tucker
Keywords: original Cc:
Game: Bud Tucker

Description

When visiting the Club again after excaping from the prison bud walks up the wall and gets stuck (see screenshot).

ScummVM Version: ScummVM 1.4.0git1894-gcee156d (Aug 31 2011 22:53:08)
Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib FluidSynth Theora

Game: German CD Version with ogg compressed audio

Ticket imported from: #3403304. Ticket imported from: bugs/5838.

Attachments (4)

tucker.2 (316 bytes ) - added by SF/async2 8 years ago.
Savegame with stuck bud
scumm.png (163.1 KB ) - added by SF/async2 8 years ago.
Screenshot
tucker.1 (300 bytes ) - added by SF/async2 8 years ago.
Savegame right after escaping and before getting stuck
tucker.md5 (52.3 KB ) - added by SF/async2 8 years ago.
md5 of data files

Download all attachments as: .zip

Change History (16)

by SF/async2, 8 years ago

Attachment: tucker.2 added

Savegame with stuck bud

by SF/async2, 8 years ago

Attachment: scumm.png added

Screenshot

by SF/async2, 8 years ago

Attachment: tucker.1 added

Savegame right after escaping and before getting stuck

comment:1 by digitall, 8 years ago

Summary: Bud cannot walk in club after visiting the 2nd timeTUCKER: Bud cannot walk in club after visiting the 2nd time

comment:2 by digitall, 8 years ago

async: Thank you for your bug report. Could you answer the following to help progress this bug:
1. Please can you indicate your Operating System?
2. Can you replicate this bug with the current stable v1.3.1 ?
3. Please attach a file list with md5sums of your game datafiles so we can eliminate corrupted data.

by SF/async2, 8 years ago

Attachment: tucker.md5 added

md5 of data files

comment:3 by SF/async2, 8 years ago

> 1. Please can you indicate your Operating System?
Windows 7 Ultimate x64, using 32bit Scummvm

> 2. Can you replicate this bug with the current stable v1.3.1 ?
Yes happens there to, just go back to speedy street and talk to wera

> 3. Please attach a file list with md5sums of your game datafiles so we can
eliminate corrupted data.
see attached files

sry that it took so long.

comment:4 by digitall, 8 years ago

async: Thank you giving the full information needed to progress this.
I have the same version of Bud (German CD) and I can confirm that your MD5sums match mine, so it is unlikely that you have datafile corruption.
I will try to replicate with the attached savegames and do a basic investigation, though please be aware I'm not an expert on the Tucker engine, so this may take a while.. Please standby.

It would be helpful if you could do the following:
1. Try this issue (hopefully just from the savegame, but you may have to replay to this point) with earlier releases of ScummVM i.e. v1.2.1, v1.2.0, v1.1.0, v1.0.0 and v0.13.1 to confirm if this is a regression or has always been a problem.
2. Try this with the original DOS interpreter under DOSBox to confirm if this occured in the original interpreter.
3. If this is a regression and you are technically capable, then performing a git bisection on ScummVM source code to work out the point of breakage would be useful.
These are not essential for you to do, but would save myself and the developers some time... Thanks.

comment:5 by digitall, 8 years ago

Owner: set to cyxx

comment:6 by digitall, 8 years ago

Replicated. This seems to only occur if you click a "Walk To" after Bud has entered the club, but before he has stopped the walking from the entry point on the left.. Probably a minor issue in the pathfinding.

I don't know if this is a bug, but more problematically there is no active exit hotspot on the left so you can't leave the club again. This may be related.

comment:7 by digitall, 6 years ago

Owner: cyxx removed

comment:8 by digitall, 6 years ago

cyx is retired, unassigning from him.

comment:9 by bonki, 23 months ago

This also happens the first time you walk into the club (i.e. game state information doesn't matter). On top of that, the bug also exists in the original interpreter (replicated in the English version).

I assume this has to do with that one is allowed to interact/click around while the Bud animation action is being executed. This is different from how other rooms are entered.

Last edited 23 months ago by bonki (previous) (diff)

comment:10 by bonki, 23 months ago

Priority: normallow
Summary: TUCKER: Bud cannot walk in club after visiting the 2nd timeTUCKER: Bud allowed to walk outside walkable area when visiting the club

Lowering prio since the original interpreter behaves the same.

comment:11 by bonki, 22 months ago

Keywords: original added

comment:12 by bonki, 22 months ago

Owner: set to bonki
Priority: lownormal
Resolution: fixed
Status: newclosed

Fixed in c55ee3f967be191c4b7ca481b266ee55f7b437b8.

Note: See TracTickets for help on using tickets.