Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5834 closed defect (fixed)

SCI: pq2-pc98-jp - Listing of items / Inventory not working

Reported by: SF/andreisv Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Police Quest 2

Description

Police Quest II: The Vengance (PC98/Japanese)
ScummVM: 1.3.1 with SJIS.FNT created by create_sjisfnt

Listing of items does not work. It affects both following cases:
1. Looking at places containing items shows an empty list.
2. Looking at inventory shows an empty list.

Steps to reproduce:
1. Immediately after starting PQ2, enter commands "open compartment" and "look compartment" - an empty list of items is displayed.
2. after taking items - for example "take keys", typing "inventory" - produces an empty list, not showing inventory content.

Ticket imported from: #3396887. Ticket imported from: bugs/5834.

Attachments (1)

pq2-pc98-jp_ListingItems.jpg (55.8 KB ) - added by SF/andreisv 8 years ago.
pq2-pc98-jp - Listing of items problem

Download all attachments as: .zip

Change History (12)

by SF/andreisv, 8 years ago

pq2-pc98-jp - Listing of items problem

comment:1 by wjp, 8 years ago

Summary: pq2-pc98-jp - Listing of items / Inventory not workingSCI: pq2-pc98-jp - Listing of items / Inventory not working

comment:2 by wjp, 8 years ago

Is it only a visual problem? I.e., does the game otherwise behave as if you have the items?

Could you also test with a daily build of ScummVM? It is possible that this is the same bug as #3368821, which we fixed last month.

comment:3 by SF/andreisv, 8 years ago

The problem persists also with latest SVN 1.4.0git1759-g8935c7c (Aug 23 2011 04:09:19).

comment:4 by SF/andreisv, 8 years ago

It is a visual problem - it acts as if I have the items.

comment:5 by wjp, 8 years ago

Could you try the following?

Start PQ2, enter the command "open compartment"

Press Ctrl-Shift-D to enter our debugger
Enter the command "logkernel Format on"
Enter the command "logkernel StrCat on"
(Note that these commands are case sensitive)
Enter the command "go" to leave the debugger again

Back in the game, enter "look in compartment", and then enter the debugger again with Ctrl-Shift-D.
You should see a few lines that look like

kFormat: 000b:00c2 (' car registration'), 995, 0, 0001:1c5a ('car registration') = 000b:00c2
kStrCat: 000b:00fe ('In the glove compartment you see: car registration'), 000b:00c2 (' car registration') = 000b:00fe
kStrCat: 000b:00fe ('In the glove compartment you see: car registration,'), 0009:01ab (',') = 000b:00fe
kFormat: 000b:00c2 (' your LPD business card'), 995, 0, 0001:1c98 ('your LPD business card') = 000b:00c2
kStrCat: 000b:00fe ('In the glove compartment you see: car registration, your LPD business card'), 000b:00c2 (' your LPD business card') = 000b:00fe
kStrCat: 000b:00fe ('In the glove compartment you see: car registration, your LPD business card.'), 0009:01ad ('.') = 000b:00fe

Could you report what you get? (The first few lines may have scrolled off-screen, but please copy those too)

comment:6 by SF/andreisv, 8 years ago

Hello, the debug output follows. If you need me to check anything further, I'd be happy to help.

kFormat: 0012:0000 ('l'), 996, 0, 108 = 0012:0000
kStrCat: 000b:0140 ('In the glove compartment you see:%JâOâìü[âuâ{âbâNâXé╔éáéΘéαé╠é═üAcar registration%JÄ╘é╠ôoÿ^Å╪'), 0001:20e0 ('car regi
tion%JÄ╘é╠ôoÿ^Å╪') = 000b:0140
kStrCat: 000b:0140 ('In the glove compartment you see:%JâOâìü[âuâ{âbâNâXé╔éáéΘéαé╠é═üAcar registration%JÄ╘é╠ôoÿ^Å╪, %JüA'), 0009:0217 (',
') = 000b:0140
kStrCat: 000b:0140 ('In the glove compartment you see:%JâOâìü[âuâ{âbâNâXé╔éáéΘéαé╠é═üAcar registration%JÄ╘é╠ôoÿ^Å╪, %JüAyour LPD business
%JâèâbâgâôîxÄ@ÅÉé╠û╝Äh'), 0001:215a ('your LPD business card%JâèâbâgâôîxÄ@ÅÉé╠û╝Äh') = 000b:0140
kStrCat: 000b:0140 ('In the glove compartment you see:%JâOâìü[âuâ{âbâNâXé╔éáéΘéαé╠é═üAcar registration%JÄ╘é╠ôoÿ^Å╪, %JüAyour LPD business
%JâèâbâgâôîxÄ@ÅÉé╠û╝Äh.%JüB'), 0009:021e ('.%JüB') = 000b:0140

comment:7 by SF/andreisv, 8 years ago

Please disregard my previous comment, after posting I noticed the paste was partial. Please look at the following:

kFormat: 0012:0000 ('l'), 996, 0, 108 = 0012:0000
kStrCat: 000b:0140 ('In the glove compartment you see:%JâOâìü[âuâ{âbâNâXé╔éáéΘéαé╠é═üAcar registration%JÄ╘é╠ôoÿ^Å╪'), 0001:20e0 ('car registration%JÄ╘é╠ôoÿ^Å╪') = 000b:0140
kStrCat: 000b:0140 ('In the glove compartment you see:%JâOâìü[âuâ{âbâNâXé╔éáéΘéαé╠é═üAcar registration%JÄ╘é╠ôoÿ^Å╪, %JüA'), 0009:0217 (', %JüA') = 000b:0140
kStrCat: 000b:0140 ('In the glove compartment you see:%JâOâìü[âuâ{âbâNâXé╔éáéΘéαé╠é═üAcar registration%JÄ╘é╠ôoÿ^Å╪, %JüAyour LPD business card%JâèâbâgâôîxÄ@ÅÉé╠û╝Äh'), 0001:215a ('your LPD business card%JâèâbâgâôîxÄ@ÅÉé╠û╝Äh') = 000b:0140
kStrCat: 000b:0140 ('In the glove compartment you see:%JâOâìü[âuâ{âbâNâXé╔éáéΘéαé╠é═üAcar registration%JÄ╘é╠ôoÿ^Å╪, %JüAyour LPD business card%JâèâbâgâôîxÄ@ÅÉé╠û╝Äh.%JüB'), 0009:021e ('.%JüB') = 000b:0140

comment:8 by wjp, 8 years ago

Something clearly seems to be going wrong with the multi-language strings. We may be calling getSciLanguageString()/strSplit() at the wrong time for the string manipulations done here to work. This needs to be investigated further.

comment:9 by SF/andreisv, 8 years ago

I understand. If there's any further information I can provide, please let me know.

comment:10 by bluegr, 8 years ago

Fixed in rd570b41

comment:11 by bluegr, 8 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.