Opened 8 years ago

Closed 7 years ago

Last modified 13 months ago

#5833 closed defect (fixed)

GUI: Font-Background Color Contrast Problem in Modern Theme

Reported by: SF/simsaw Owned by: lordhoto
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

When looking at the credits list using the modern theme, the text written in gray color is hard to read. It seems to be fine in the classic theme though as the contrast between the colors seems to be better there.

As sev pointed out, this is because there is "disabled text" used. This color cannot be changed for now. It would be necessary to make this one adaptable for the themes.

Ticket imported from: #3395057. Ticket imported from: bugs/5833.

Attachments (1)

about-text.patch (636 bytes ) - added by digitall 8 years ago.
Workaround Patch For About/Credits Dialog

Download all attachments as: .zip

Change History (13)

comment:1 by SF/simsaw, 8 years ago

Owner: set to sev-

comment:2 by digitall, 8 years ago

Attaching patch to "fix" this by changing from the "Disabled" to "Normal" text in the About Dialog, but this is not optimal.

I suspect the most optimal solution would involve changing the function AboutBox::drawDialog() later on in the gui/about.cpp file which maps these initial codes to widget font/color/state.

comment:3 by digitall, 8 years ago

Summary: Gray color hard to see on modern themeGUI: Font-Background Color Contrast Problem in Modern Theme

comment:4 by digitall, 8 years ago

It should be noted that this issue goes beyond just the Credits / About Dialog and encompasses any time that kDisabled i.e. Light Grey Text is used on the Yellow background...

by digitall, 8 years ago

Attachment: about-text.patch added

Workaround Patch For About/Credits Dialog

comment:5 by digitall, 7 years ago

It should be noted that simsaw said "This color cannot be changed for now".
I think it is because it was thought that the color is hardcoded in ScummVM theme renderer code.
Since the Classic theme has a dark background and the Modern Theme has a light background, if a "fix" was made for one, the contrast with the other would be made worse, so the fix was to ensure that the disabled text and other color settings are made configurable within the theme...

comment:6 by digitall, 7 years ago

However, investigation by LordHoto shows that this is not hardcoded. This is adjustable by changing lines 155-157 in scummmodern_gfx.stx and the equivalent lines in scummclassic_gfx.stx:

<text_color id = 'color_normal_disabled'
color = '192, 192, 192'
/>

comment:7 by digitall, 7 years ago

So changing this in the theme files is possible.
The only sticking point is where else "disabled" text is used and whether changing it could cause contrast/design issues.
A quick audit by LordHoto has shown:
* The only real code using drawText directly seem to be: edit text widget, list, editable widget in general, about, tooltip, popup
* The console always uses color_normal_enabled as far as I can tell right now and that's the only code using drawChar.

Since "As far as I can tell the disabled checkbox text isn't easier to read in the options menu.", it looks like the other cases are actually just as bad.

comment:8 by lordhoto, 7 years ago

Owner: changed from sev- to lordhoto
Resolution: fixed
Status: newpending

comment:9 by lordhoto, 7 years ago

This should be fixed with fee19db7eedb16d7e7d62429f6c0eb4770bc07c3. I made the disabled color a bit darker. It is still noticeable different from the normal color though. But if you have a better color suggestion you are welcome to tell us about it.

Marking this as pending untill it's confirmed as fixed.

comment:10 by bluegr, 7 years ago

This has not been closed automatically, and it's pretty old now. Closing manually.

comment:11 by bluegr, 7 years ago

Status: pendingclosed

comment:12 by digitall, 13 months ago

Component: GUI
Note: See TracTickets for help on using tickets.