Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5825 closed defect (fixed)

LOOM: CD-Version crashes at start

Reported by: SF/apprentice-fu Owned by: lordhoto
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

ScummVM 1.4.0git1421-gf049e67 (Aug 10 2011 17:31:52)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora

The CD-Version of Loom crashes at the beginning of the game. This seems the happen when the function startCDTimer() in engine/scumm/sound.cpp is called the second time.
This behavior seems to be introduced by commit 4c7958450f628937270f ("TIMER: Implemented checks for duplicated timers" from 2011-08-05).
Reproduce:
Start Loom, choose a difficulty
Error message: (69:1:0x351): Same callback is referred by different names (scummCDtimer vs scummCDtimer)!

Version Loom CD, English

Ticket imported from: #3389673. Ticket imported from: bugs/5825.

Change History (2)

comment:1 Changed 8 years ago by lordhoto

Fixed with cea06991ebab97c72e9fd89a4bf63835bcf0de80. Thank you for reporting.

comment:2 Changed 8 years ago by lordhoto

Owner: set to lordhoto
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.