Opened 8 years ago

Closed 8 years ago

Last modified 7 months ago

#5822 closed defect (invalid)

Gabriel Knight 1 Dialog Trees are busted

Reported by: SF/brianmwilkerson Owned by: SF/mthreepwood
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game:

Description

Any item in a dialog tree which contains more than one word (for instance 'voodoo murders') is treated as two options, dropping the second word down to the next line, where it overlaps with the next option. This makes all dialog unplayable. Also, the characters' dialog spills off the edge of the screen and over the characters' faces. Finally, some options seem to be treated as dialog, appearing above characters' heads and therefore becoming unclickable.

Tried to change all graphic options, and ran both the windows and dos versions.

Thanks!

Ticket imported from: #3388123. Ticket imported from: bugs/5822.

Change History (3)

comment:1 Changed 8 years ago by SF/mthreepwood

We don't support GK1 for a reason, closing as invalid.

However, the overlapping dialog does not make it any less playable than before the regression when the lines were working better. Since we do not properly handle SCI32 text size, the hotspot for the text is confined to the top-left most pixels of the line of dialog text.

comment:2 Changed 8 years ago by SF/mthreepwood

Owner: set to SF/mthreepwood
Resolution: invalid
Status: newclosed

comment:3 Changed 7 months ago by digitall

Component: Engine: SCI
Note: See TracTickets for help on using tickets.