Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#5820 closed defect (duplicate)

SCI: LONGBOW - Crash in the Sherwood forest.

Reported by: SF/jinx1337 Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Conquests of the Longbow

Description

The game crashes upon entering a specific 'room' in the Sherwood forest.

The engine throws out a specific error, screencap enclosed.

The game was patched with the official SIERRA update.

Ticket imported from: #3387834. Ticket imported from: bugs/5820.

Attachments (1)

cotlcrash.jpg (29.5 KB ) - added by SF/jinx1337 8 years ago.
Screecap of the error.

Download all attachments as: .zip

Change History (12)

by SF/jinx1337, 8 years ago

Attachment: cotlcrash.jpg added

Screecap of the error.

comment:1 by digitall, 8 years ago

Summary: COTL: Crash in the Sherwood forest.SCI: LONGBOW - Crash in the Sherwood forest.

comment:2 by digitall, 8 years ago

Jinx1337: Thank you for the bug report. In order to progress this, could you provide the following information:
* ScummVM Version (1.3.1?). If this was a v1.4.0pre daily build, please provide full version.
* Operating System
* Exact Version of Game. For SCI games, this is usually found in the VERSION file or by using the menu bar for information. (This would be prior to patching, if you could also provide a link to the patch you used as well)

Also, could you please attach a savegame to allow replication?
And finally, if you used v1.3.1 (stable), could you try a v1.4.0pre daily build (development) to see if this bug has already been fixed in the development builds:
http://www.scummvm.org/downloads/#daily

comment:3 by digitall, 8 years ago

OK, a little investigation prework for the SCI engine devs:

The error message in the attached screencapture is:
"ERROR: Invalid arithmetic operation (params: 002a:0007 and 0000:ffff) from method ::export 2 (room 220, script 2 ffffff)!"

Checking in engines/sci/engine/workarounds.cpp, there is not currently a workaround for this, so this is probably another buggy script in the original.

comment:4 by bluegr, 8 years ago

Need a savegame to test this, as it's a script bug, and if a workaround is added without testing it, it can lead to more problems than the ones it actually solves

comment:5 by bluegr, 8 years ago

Please attach a saved game, as I can't reproduce this. Marking as "pending".

comment:6 by bluegr, 8 years ago

Owner: set to bluegr
Resolution: worksforme
Status: newpending

comment:7 by bluegr, 8 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:8 by bluegr, 8 years ago

There has been no activity on this tracker item for more than 5 months. Closing because of lack of information (and this should have been done automatically - odd)

comment:9 by bluegr, 8 years ago

Status: pendingclosed

comment:10 by m-kiewitz, 4 years ago

Resolution: worksformeduplicate

comment:11 by m-kiewitz, 4 years ago

this seems to be a duplicate of 6751

Note: See TracTickets for help on using tickets.