Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#5812 closed defect (fixed)

WAXWORKS: Reappearance of dead vampire

Reported by: SF/maniac242 Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Waxworks

Description

When entering the chapel on the cemetary a huge bat appered, transforming into a vampire. He was killed. When saving the game right after killing, quiting ScummVM and reloading the savegame make the vampire reappear. As soon as he transforms the movecontrolls were blocked but the vampire will not kill the player and can't be killed without the pile.

This behavior first happened on the stable Version 1.3.1 (Win7-64) and could be reproduced on the daily build (ScummVM 1.4.0git1191-gf3c1033 (Jul 26 2011 04:09:25) Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib), on Vista-64.

I Played the unpatched German PC Floppy-Edition.

Attached there were 2 Savegames: "test" in front of the chaple and "in chap." after killing the vampire.

Ticket imported from: #3378910. Ticket imported from: bugs/5812.

Attachments (2)

waxworks-pc.001 (3.5 KB) - added by SF/maniac242 8 years ago.
"test" in front of the chaple
waxworks-pc.002 (3.5 KB) - added by SF/maniac242 8 years ago.
"in chap." after killing the vampire

Download all attachments as: .zip

Change History (16)

Changed 8 years ago by SF/maniac242

Attachment: waxworks-pc.001 added

"test" in front of the chaple

Changed 8 years ago by SF/maniac242

Attachment: waxworks-pc.002 added

"in chap." after killing the vampire

comment:1 Changed 8 years ago by SF/maniac242

Summary: Reappearance of dead vampireWAXWORKS: Reappearance of dead vampire

comment:2 Changed 8 years ago by digitall

maniac242: Could you please confirm if this occurs with v1.3.0?

Checking the commits between v1.3.0 and v1.3.1, there are no changes to AGOS engine.
If you confirm this is missing from v1.3.0, then this is probably an un-initialized read bug or similar which gives an unstable replication.

comment:3 Changed 8 years ago by SF/maniac242

Checked it with ScummVM 1.3.0 Win32 and Win64 under Vista. Behaves exactly like described above.

When killing the vampire and loading the 2nd savegame without quitting ScummVM he stays dead. When quitting and loading he reappers.

comment:4 Changed 8 years ago by digitall

maniac242:
Thanks. I have checked the engine page, TODO and BUGS list: http://wiki.scummvm.org/index.php/AGOS
The AGOS engine for Waxworks has been in ScummVM since around version 0.2.0 and nothing like this is mentioned in the TODO/BUGS so this is likely to be a regression.

Though this could be a long standing minor issue as Waxworks doesn't seem to have had a full successful release test in any release:
http://wiki.scummvm.org/index.php/Release_Testing

It would be useful if you could help in tracking this down by bisection testing releases i.e. If you try to find a good release and the first bad one; assuming that the time/work to replicate is not too hard.

I would suggest starting testing with v1.2.1, v1.1.0, v1.0.0. If it occurs with all three, then testing with v0.13.1 and v0.8.0 would be useful so we can zero in on the defective release.

comment:5 Changed 8 years ago by SF/maniac242

Afaik the early versions of the AGOS-Engine were used for Simon the Sorcerer. Waxworks was introduced first in V0.11.0 together with Elvira 1 & 2.

So ScummVM before 0.10.0 won't recognize the game (0.8.0 suggests Simon 1) and V0.10.0 -0.13.0 only knows the english Version (GOG-Release). So I used this Version for testing.

V0.10.0 could not start the game
V0.11.x start the game but throw me back to desktop when trying to load a savegame.
V0.12.0 to 1.3.1 shows the same effect described above

So this seems to be a "a long standing minor issue". Sorry.

comment:6 Changed 8 years ago by digitall

maniac242: Thanks. One of the AGOS devs will need to take a more detailed look to deteremine the cause of this, but we should have sufficient detail to progress.

comment:7 Changed 8 years ago by bluegr

There was a bug when loading Waxworks saves. This has been fixed on the 27th of August, 2011. Try using a daily build (1.4.0pre), hopefully this issue has been fixed.

Assigning to Kirben, who did the fix for this

comment:8 Changed 8 years ago by bluegr

Owner: set to Kirben

comment:9 Changed 7 years ago by bluegr

There hasn't been any feedback on this for 4 months now. This bug seems to have the same root cause as the 3 other bugs that have been submitted regarding Waxworks saves:
bugs #3378910, #3011646, #3011639, #3011635

All of these bugs have been fixed by kirben on the 27th of August (commit #5e174cbf), a fix which is included in ScummVM 1.4.0.

Since there hasn't been any feedback on this for over 4 months, it is assumed that this bug has already been fixed, thus, I'm setting this bug to pending. If you're still having issues, please reply.

comment:10 Changed 7 years ago by bluegr

Status: newpending

comment:11 Changed 7 years ago by bluegr

Resolution: fixed

comment:12 Changed 7 years ago by bluegr

Keywords: script removed

comment:13 Changed 7 years ago by bluegr

Changing from "Pending" to "Closed" (which hasn't been done automatically, for some odd reason)

comment:14 Changed 7 years ago by bluegr

Status: pendingclosed
Note: See TracTickets for help on using tickets.