Opened 8 years ago

Closed 8 years ago

#5811 closed defect (fixed)

WinCE-Nippon Safes Amiga: Crash at taxi scene

Reported by: SF/andrea2054 Owned by: digitall
Priority: normal Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

Dough path: when Dough is inside the taxi, just click anywhere and ScummVM crashes
Nippon Safes DOS version
ScummVM WinCE port 1.3.1
HP iPaq h2210 running WinCE 4.2 italian

Ticket imported from: #3378535. Ticket imported from: bugs/5811.

Attachments (1)

nippon.008 (133 bytes ) - added by SF/andrea2054 8 years ago.
Savegame to reproduce problem (taxi scene)

Download all attachments as: .zip

Change History (10)

by SF/andrea2054, 8 years ago

Attachment: nippon.008 added

Savegame to reproduce problem (taxi scene)

comment:1 by SF/andrea2054, 8 years ago

Sorry, it's the Amiga version. Maybe I have some corrupt files.

comment:2 by SF/andrea2054, 8 years ago

Summary: WinCE-Nippon Safes: Crash at taxi sceneWinCE-Nippon Safes Amiga: Crash at taxi scene

comment:3 by digitall, 8 years ago

andrea2054: This should be fixed in the latest daily build. Please can you test?

You can check your Amiga Datafiles MD5sums (from a tool such as http://md5summer.org) against the following from my version. If they give the same answer, It is unlikely that any of your files are damaged:
2e11e84e2f45f4e37a8c0ba9bac4b941 *datafiles/disk0
0c779e92c70a64cbe99fff27ee4c749c *datafiles/disk1
965e6b7d8baa2a0adb6ac0d1080a7776 *datafiles/disk2
96dd5accb206ed142c9b114d5a95a792 *datafiles/disk3
781a3739ea95387a02ca77fb132ef1c2 *datafiles/disk4
57ab1d0126de27271baa2acd12498b1c *datafiles/en
f279490bf6f51bfedf2db67ad950ac79 *datafiles/fr
ddd0db7c77d37015f02c4fa927af66a7 *datafiles/ge
7d9b5e3632a219485995652735304ca5 *datafiles/global.table
0ddef3d0c292cf9919e6cb4c08c0d667 *datafiles/pointer

comment:4 by digitall, 8 years ago

For reference, I think this was another reading out of buffer in the pathfinding which is now emitting the following warning in the taxi if I click:
"WARNING: isPathClear() _path is NULL!!"

comment:5 by digitall, 8 years ago

Changing this bug's status to Pending, since this should be fixed.

Unless the bug reporter responds to indicate the problem still exists within 14 days, this bug will be automatically closed.

comment:6 by digitall, 8 years ago

Resolution: fixed
Status: newpending

comment:7 by SF/andrea2054, 8 years ago

Status: pendingnew

comment:8 by SF/andrea2054, 8 years ago

Issue tested and confirmed solved with version 1.4.0git1931-gcb410d5.

comment:9 by wjp, 8 years ago

Owner: set to digitall
Status: newclosed
Note: See TracTickets for help on using tickets.