Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5810 closed defect (fixed)

SCI: QFG3: Unable to climb tree to monkey village

Reported by: SF/negativeiq Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

When reaching monkey village playing as Paladin (also as Fighter but I don't know whether the bug reproduces then) you're supposed to ask Manu (the monkey) to help you climb up. Specifically you're supposed to ask about help then about rope then about vines then about swing line (if I remember correctly). However when playing through ScummVM after asking about rope you can't ask about vine (it just lets you ask about rope again) so unless you have the magic user's levitate spell or the thief's climbing skill you cannot go to the village and therefore cannot finish the game. Attached it a savegame at that point.

Ticket imported from: #3377429. Ticket imported from: bugs/5810.

Attachments (1)

qfg3.005 (57.8 KB ) - added by SF/negativeiq 8 years ago.
Savegame at the point where you get stuck because of the discussed problem.

Download all attachments as: .zip

Change History (12)

by SF/negativeiq, 8 years ago

Attachment: qfg3.005 added

Savegame at the point where you get stuck because of the discussed problem.

comment:1 by SF/negativeiq, 8 years ago

Summary: Unable to climb tree to monkey villageQFG3: Unable to climb tree to monkey village

comment:2 by wjp, 8 years ago

Summary: QFG3: Unable to climb tree to monkey villageSCI: QFG3: Unable to climb tree to monkey village

comment:3 by digitall, 8 years ago

Owner: set to wjp

comment:4 by digitall, 8 years ago

Replicated with latest Git master on Linux x86_32 and the attached savegame.

Checked a walkthrough to see if this was a known issue, but it does seem like a real regression in our SCI implementation.

See the section "5. Fighter/Paladin Walkthrough" specifically the bit "The Call To War" in http://www.the-spoiler.com/RPG/Sierra/glory.quest.3.4.html which indicates this sequence:
"Head over to the Jungle, and you'll find your
last remaining friend, Manu the monkey. He'll offer to take you to the
Monkey Village. You don't really have much of a choice here. Ask him
about Village, then click the Mouth on yourself and Agree (3)."
Though this seems to omit the need to levitate or climb the tree...

comment:5 by digitall, 8 years ago

http://www.the-spoiler.com/RPG/Sierra/glory.quest.3.2.html indicates that you do need to talk to Manu as a Fighter:
"How do I get into the Monkey village?

Hint:
If you are a Magic User one of your spells is most appropriate for rising to
the occasion. If you are a Thief either use one of your natural abilities or
the gift you received from the Sultan. If you are a Fighter you are going to
have to talk to Manu and get him to help you.
"

comment:6 by wjp, 8 years ago

Owner: wjp removed

comment:7 by digitall, 8 years ago

negativeiq: This bug will require one of the SCI engine developers to step through the script code for this scene. Since this will take some time, please be patient and stand by. Thanks.

comment:8 by bluegr, 8 years ago

Seems to be a regression from the script patch for bug #3040722. If I remove the patch, the dialog progresses, but you can't ask Manu to send a swingline down (but this might be caused by the faulty patch, so the game scripts in that scene might have reached a dead end state)

comment:9 by wjp, 8 years ago

Good catch. Removing that patch does fix it. You have to ask for the swingline by clicking the talk icon on yourself, not on manu.

comment:10 by bluegr, 8 years ago

Reverted the bad script patch in

The scene works fine now. I've reopened the original bug #3040722 (which isn't severe like this one, as the dialog option associated with that one is completely optional).

comment:11 by bluegr, 8 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.