Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5808 closed defect (fixed)

GOB3: Sound glitches

Reported by: SF/zosite Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

I've heard of other sound glitches related to the GOB engine but I couldn't find any info on this particular one so...

It happens in BOTH floppy and CD versions of Goblins 3, no matter the language; I tried using USGOB3.ITK, DEGOB3.ITK, FRGOB3.ITK...
AFAIK it also happens as far as in ScummVM 0.13.1 which was the last version I used before 1.3.1, my current one (both Win32), but not the same way.

The thing is that sounds from Blount's steps are completely glitched. Usually you can't even hear them, for they are played inconsistently and that's what has been happening since 0.13.1 (maybe even before, I couldn't say). But in this last version 1.3.1 they sound much worse: now it's not only that they don't sound when they should... now they sound horrible, as if they were some sort of PC speaker -cancel- sound. Well, TBH they were quite bad to start with but...

I hope to have been of some help here; since this is the first time I report a ScummVM bug I beg your pardon in case I screwed it up. Not to mention my english... :P

Ticket imported from: #3376547. Ticket imported from: bugs/5808.

Change History (6)

comment:1 Changed 8 years ago by digitall

Owner: set to DrMcCoy

comment:2 Changed 8 years ago by digitall

zosite: The GOB engine developers have just pushed a fix for the Woodruff issue

Please can you test the next v1.4.0pre daily build from:
http://www.scummvm.org/downloads/#daily
to confirm if this is corrected in the latest development version. Thanks.

comment:3 Changed 8 years ago by SF/zosite

Well, I've just tried the very last daily build (file named mingw-w32-master-74e43312 in case it means something in terms of build time) and the answer is a resounding NO. The bug is still there and it behaves exactly the same.

On the other hand, it seems the SDL version that comes with this build is 1.2.13 instead 1.2.14 (v 1.3.1) in case you find it useful.

comment:4 Changed 8 years ago by DrMcCoy

Okay, fixed the issue in commit a852f30fb272c4b6adec898a09f3fe8c1f631b90.

Should be okay in the next daily build, thanks for reporting.

comment:5 Changed 8 years ago by DrMcCoy

Resolution: fixed
Status: newclosed

comment:6 Changed 8 years ago by SF/zosite

Fixed indeed! Thanks a lot for your attention!

Note: See TracTickets for help on using tickets.