Opened 8 years ago

Closed 8 years ago

#5804 closed defect (fixed)

WOODRUFF: Missing sound effects

Reported by: SF/gimlao Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Woodruff

Description

No foot step sounds while going to another screen.

No music/sounds while Woodruff is picking up the two boots on the ground at the beginning.
Same thing while he's pulling on the boots and while he's discovering the photo in the first one.

Those sound are playing well in the vers 1.1.1 of ScummVM.
They are missing since the next version (1.2.0).

Ticket imported from: #3374170. Ticket imported from: bugs/5804.

Change History (13)

comment:1 by SF/mthreepwood, 8 years ago

Summary: Missing sound effectsWOODRUFF: Missing sound effects

comment:2 by digitall, 8 years ago

Both DrMcCoy and myself have replicated this issue and I have confirmed the sound effects present in v1.1.1 and missing in v1.2.0. Running Git bisection for the cause of this issue.

comment:3 by digitall, 8 years ago

Owner: set to DrMcCoy

comment:4 by digitall, 8 years ago

OK. Bisection indicates this commit as the cause of the missing foot step sounds while changing screens:
commit 8e523d9d2fc471ef1ef25ac26b9f7053a382192e
Author: Sven Hesse <drmccoy@users.sourceforge.net>
Date: Thu Oct 7 09:18:15 2010 +0000

GOB: Fix object videos with more than 255 frames

A regression of the CoktelDecoder rewrite.

svn-id: r53043

Not sure if this is the same issue with the boots... Will need to play through to that point before and after.

comment:5 by digitall, 8 years ago

I can confirm that reversing that commit on the latest Git master does restore the footsteps, so definately the cause of that.

comment:6 by digitall, 8 years ago

I can also confirm that the boots/photo missing noises are restored by reversing this commit as well... Not sure why this affects this..

comment:7 by digitall, 8 years ago

Fixed by DrMcCoy in 74e43312f73d86962df54edb2910cf4dec30ae89.

Gimlao: Please can you test the next v1.4.0pre daily build from:
http://www.scummvm.org/downloads/#daily
to confirm this is corrected for you. Thanks.

comment:8 by digitall, 8 years ago

Resolution: fixed

comment:9 by digitall, 8 years ago

Setting to pending. If no further user response is given, this will be closed automatically in 14 days.

comment:10 by digitall, 8 years ago

Status: newpending

comment:11 by SF/gimlao, 8 years ago

Status: pendingnew

comment:12 by SF/gimlao, 8 years ago

Sorry, I forgot to say it was fixed (since the 2011-07-23). ^^;

comment:13 by digitall, 8 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.