Opened 7 years ago

Last modified 11 months ago

#5802 new defect

SYMBIAN: Bad green colors on Nokia N73 Music Edition

Reported by: SF/imb00t Owned by: anotherguest
Priority: normal Component: Ports
Keywords: Cc:
Game:

Description

ScummVM 1.3.0 and older versions launch with bad green colors (see screenshots).

If the App key is pressed for a few seconds, the colors go back to normal, but after another few seconds, they screw up yet again.

This bug seems to be old (http://forums.scummvm.org/viewtopic.php?t=5619), but it wasn't ever fixed. After some research on my side, it appears that this is a N73 exclusive issue and also happens with the S60v3 game Crash Bandicoot Kart 3D (not sure if this is relevant, but I had to point it out).

My phone is using the latest firmware available.

NOTE: The screenshots are from the thread mentioned above and I do not own them in any way, but my only intentions are to help in resolving this ScummVM bug.

Ticket imported from: #3372340. Ticket imported from: bugs/5802.

Attachments (4)

6r50fq.jpg (12.2 KB) - added by SF/imb00t 7 years ago.
Screenshot1
16ad6yd.jpg (13.9 KB) - added by SF/imb00t 7 years ago.
Screenshot2
vru03s.jpg (15.6 KB) - added by SF/imb00t 7 years ago.
Screenshot3
xp1lrn.jpg (13.5 KB) - added by SF/imb00t 7 years ago.
Screenshot4

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by SF/imb00t

Attachment: 6r50fq.jpg added

Screenshot1

Changed 7 years ago by SF/imb00t

Attachment: 16ad6yd.jpg added

Screenshot2

Changed 7 years ago by SF/imb00t

Attachment: vru03s.jpg added

Screenshot3

Changed 7 years ago by SF/imb00t

Attachment: xp1lrn.jpg added

Screenshot4

comment:1 Changed 7 years ago by digitall

Owner: set to anotherguest

comment:2 Changed 7 years ago by digitall

This looks like an issue with the Symbian Graphics backend, so assigning to the maintainer, anotherguest.

Though from reading the thread, I think he has taken a look at this previously with no success.

It seems that a number of people have had this issue so it is real, but it is not exclusively ScummVM.
Something to do with multiple applications interfering with the screenmode.
Two workarounds are listed:
#1:
1) start scummvm
2) press app key to return to menu
3) start vboy (vampent game boy emulator)
4) hold app button and switch to scummvm
5) hold app button and switch to vboy (to set this app on top)
6) exit vboy

#2:
0. Install ScummVM
1. copy an arbitrary .swf animation on the phone
1. start SCUMMVM
2. Press AppKey -> Gallery -> Presentations (or All Files)
3. open your .swf
4. hold app key until the menu appears, switch to Scummvm
5. In same manner, switch back to "gallery"
6. press "Back" (video closes) - "Back" (now in gallery main menu) - "Close"
7. et voila, ScummVM with correct colors.

Not sure whether this sheds any light on the issue.

comment:3 Changed 7 years ago by digitall

anotherguest: Do we have automated daily builds for SymbianOS? Just that the latest I can find is 20110131 here:
http://anotherguest.se/cvsbuilds/

comment:4 Changed 7 years ago by SF/imb00t

Not meaning to offend, but what kind of solution methods are these? Use vBoy? Copy a .swf file and switch to gallery? I've seen them, of course, and no, they do not work, at least not for me. Besides, doing all of that just so ScummVM could have normal colors? What a pain. I'd really prefer a permanent solution.

And regarding the "multiple applications" thing you said. When I hold the App key while I'm in ScummVM all I see is Standby and Music player. How could these two be the problem? Or perhaps it's something hidden. I have KillMe installed, so perhaps it could be of some help?

Thanks for the answer, anyway.

comment:5 Changed 7 years ago by digitall

imb00t: _PLEASE_ This is a bug tracker, not a forum thread, so please lose the attitude and the inflammatory language as it is not helpful.

I didn't post the workarounds aimed at you, but to see if they would help the port maintainer shed any light on the possible cause of this issue in the backend i.e. what GFX functions are called and what state is affected on Application switch, which might explain the issue.

comment:6 Changed 7 years ago by SF/imb00t

UPDATE: Again, not sure if it's of any relevance, but this problem occurs on the game Polarbit Raging Thunder (3D), as well.

comment:7 Changed 11 months ago by csnover

Component: Ports
Note: See TracTickets for help on using tickets.