Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#5784 closed defect (invalid)

DREAMWEB: Crash when confronting Beckett

Reported by: tsoliman Owned by: SF/megath
Priority: normal Component: Engine: Dreamweb
Keywords: Cc:
Game: Dreamweb

Description

scummvm: ../engines/dreamweb/runtime.h:73: DreamGen::WordRef::WordRef(Common::Array<unsigned char>&, unsigned int): Assertion `index + 1 < data.size()' failed.

Linux self compiled git 559c278

To reproduce, load the attached savegame and exit left. Beckett will say a few lines and then crash.

Ticket imported from: #3355078. Ticket imported from: bugs/5784.

Attachments (1)

DREAMWEB.D00 (15.1 KB ) - added by tsoliman 8 years ago.
savegame: exit left

Download all attachments as: .zip

Change History (7)

by tsoliman, 8 years ago

Attachment: DREAMWEB.D00 added

savegame: exit left

comment:1 by SF/megath, 8 years ago

what version do you use?

comment:2 by SF/megath, 8 years ago

sorry for being unspecific, what version/language of dreamweb does crash for you ?

comment:3 by tsoliman, 8 years ago

I had a modified the CD version (to take the speech out) but with the unmodified version it works fine.
This issue can be closed since we don't support hacked up versions.

comment:4 by tsoliman, 8 years ago

Resolution: invalid

comment:5 by digitall, 8 years ago

Owner: set to SF/megath
Status: newclosed

comment:6 by digitall, 7 years ago

Component: Engine: Dreamweb
Game: Dreamweb
Note: See TracTickets for help on using tickets.