Opened 8 years ago

Closed 7 years ago

#5763 closed defect (fixed)

WinCE: Nippon Safes: Objects didn't appear

Reported by: SF/andrea2054 Owned by: CeRiAl
Priority: normal Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

It's impossible to play Nippon Safes because objects didn't appear on the screen.
For example, in the starting location of Dino path (the museum), all the lower statues and the fire extinguisher are missing. If you know where the objects are you can pick them up (the hotspot is working), but then the object doesn't appear in the inventory and it's lost forever.
This is a regression. I noticed it in v1.1.1 and v1.2.0, it is solved in v1.3.0 but the latest stable build 1.3.0pre115-ge17a33c (WinCE port) has the issue again.
HP iPAQ h2200, WinCE 4.20

Ticket imported from: #3322951. Ticket imported from: bugs/5763.

Attachments (1)

Nippon Safes.jpg (20.8 KB) - added by SF/andrea2054 8 years ago.
No objects to interact with in Museum scene

Download all attachments as: .zip

Change History (27)

comment:1 Changed 8 years ago by lordhoto

Summary: WinCE-Nippon Safes:objects didn't appearNippon Safes: WinCE: Objects didn't appear

comment:2 Changed 8 years ago by lordhoto

Summary: Nippon Safes: WinCE: Objects didn't appearWinCE: Nippon Safes: Objects didn't appear

comment:3 Changed 8 years ago by digitall

cerial23: I assume this might be fixed by your work on the backend.

andrea2054: Can you test with the latest development daily build and see
if this is still occuring for you?:
http://buildbot.scummvm.org/builds.html

comment:4 Changed 8 years ago by SF/andrea2054

Resolution: fixed

comment:5 Changed 8 years ago by SF/andrea2054

The bug is now fixed in version 1.3.1

comment:6 Changed 8 years ago by digitall

andrea2054: Thanks for the update.
Since this is now fixed, I will close this bug, but I will leave comment posting open.
Since this seems to be an unstable bug, we don't know exactly why this was occuring and how it has been fixed,
if you could update this bug if this starts occuring again, then we can look into this further.

comment:7 Changed 8 years ago by digitall

Owner: set to CeRiAl
Status: newclosed

comment:8 Changed 8 years ago by peres

I reopened the bug in response of the request from the original poster at http://forums.scummvm.org/viewtopic.php?t=10571.

I believe this is a problem with the backend, but please attach a screenshot anyway: there could be helpful details for a trained eye.

comment:9 Changed 8 years ago by peres

Status: closednew

comment:10 Changed 8 years ago by peres

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

Changed 8 years ago by SF/andrea2054

Attachment: Nippon Safes.jpg added

No objects to interact with in Museum scene

comment:11 Changed 8 years ago by SF/andrea2054

I've attached the screenshot as requested.
It shows the starting location for Dino (the museum), but it happens on every location.
I've used the version 1.4.0git1074-g5a1d0ab

comment:12 Changed 8 years ago by SF/andrea2054

Resolution: fixedwontfix

comment:13 Changed 8 years ago by SF/andrea2054

Resolution: wontfix

comment:14 Changed 8 years ago by digitall

andrea2054: Could you check this with the latest daily build and see if it still occurs?
If so, could you check the same build for your desktop platform i.e. win32.

This should confirm if this is a WinCE specific issue.

comment:15 Changed 8 years ago by SF/andrea2054

Issue tested and confirmed not solved with version 1.4.0git1931-gcb410d5.
It is a WinCE specific issue (it does not happen with the same build for Win32) and it seems to happen only on daily builds; official versions works correctly.

comment:16 Changed 7 years ago by SF/andrea2054

With the official version 1.4.0 (full executable) the issue is solved, but is back again with the 1.5.0git859-gf9ad14d

comment:17 Changed 7 years ago by wjp

I haven't looked into this myself at all, but this is starting to sound a bit like a compiler bug in the specific compiler version we use for the daily WinCE builds on buildbot, I think.

comment:18 Changed 7 years ago by digitall

wjp: I agree... Either the compiler or the library dependencies/headers, specifically SDL probably.

It is currently "mingw32ce-0.5.1", which also contains all the libraries etc. and can be found in /opt/toolchains on the buildbot.

knakos did update the libSDL.a in the toolchain at v1.3.1, but I think the entire compiler could do with an update.
cerial23: Any POV on this?

comment:19 Changed 7 years ago by digitall

For reference:
http://wiki.scummvm.org/index.php/Compiling_ScummVM/Windows_CE

comment:20 Changed 7 years ago by CeRiAl

I also agree that it may indeed be a compiler bug, as the official release builds don't have these problems - I'm using a newer version of mingw32ce, specfically "mingw32ce-0.59.1" for the official builds. I don't think the problems relate to SDL, though. The SDL libraries on buildbot have been updated for ScummVM 1.3.1 as I've fixed some SDL related bugs back then. So the library on buildbot should be ok. I'm in the process of updating the compiling instructions for Windows CE in the wiki right now, and as soon as this is done, I will report back so that the mingw32ce toolchain on buildbot could be updated with version 0.59.1. I've meanwhile also again fixed another problem in the SDL library (related to the "32MB per process max. on Windows CE < 6" problem) so SDL will need to updated also then.

comment:21 Changed 7 years ago by digitall

cerial23: Thank you for this response. When you are ready, please contact me in the #scummvm IRC channel and we will deal with setup and install of the new toolchain on buildbot.

comment:22 Changed 7 years ago by CeRiAl

tdhs: I've finally finished editing the wiki-page (and double checked that everything works as described on a fresh machine) - but didn't had time yet to meet you in IRC. I hope it will be possible tomorrow, if not I'll be contacting you by email (hope this is also ok).

comment:23 Changed 7 years ago by digitall

andrea2054: The buildbot WinCE toolchain has now been updated.. Daily builds should be fixed and as per release.
Could you check the latest daily build please to check?

comment:24 Changed 7 years ago by SF/andrea2054

Now the version 1.5.0git1527-g538d834 (Dec 19 2011) works!
Thank you very much!

comment:25 Changed 7 years ago by digitall

andrea2054: Thank you for your patience. Please could you check and update status on any other bugs you may have opened which may be fixed...

comment:26 Changed 7 years ago by digitall

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.