Opened 8 years ago

Closed 8 years ago

Last modified 11 months ago

#5734 closed defect (invalid)

Operation Stealth 256 DOS/US version ("Mr.Bond") crash 1.3.0

Reported by: SF/markcoolio Owned by: bluegr
Priority: normal Component: Engine: Cine
Keywords: Cc:
Game: Operation Stealth

Description

The above version of Operation Stealth (US 256 colors "Stealth Affair") crashes when being launched from 1.3.0 version:

User picked target 'os-us-1' (gameid 'cine')...
Looking for a plugin supporting this gameid... Cinematique evo 1 engine
Starting 'Cinematique evo.1 engine game'
WARNING: loadResource: Ignoring file 'APPLAUSE.H32' (Load at 0)!
WARNING: loadResource: Ignoring file 'AVION___.H32' (Load at 1)!
WARNING: loadResource: Ignoring file 'BIP00105.H32' (Load at 2)!
WARNING: loadResource: Ignoring file 'BIP2____.H32' (Load at 3)!
WARNING: loadResource: Ignoring file 'BIP_____.H32' (Load at 4)!
WARNING: loadResource: Ignoring file 'BULLES__.H32' (Load at 5)!
WARNING: loadResource: Ignoring file 'CRACK___.H32' (Load at 6)!
WARNING: loadResource: Ignoring file 'CRISSE__.H32' (Load at 7)!
WARNING: loadResource: Ignoring file 'DOUCHE__.H32' (Load at 8)!
WARNING: loadResource: Ignoring file 'EAU_____.H32' (Load at 9)!
WARNING: loadResource: Ignoring file 'EGOUT_75.H32' (Load at 10)!
WARNING: loadResource: Ignoring file 'EXPLOSE_.H32' (Load at 11)!
WARNING: loadResource: Ignoring file 'MER2____.H32' (Load at 12)!
WARNING: loadResource: Ignoring file 'MER_____.H32' (Load at 13)!
WARNING: loadResource: Ignoring file 'MITRAILL.H32' (Load at 14)!
WARNING: loadResource: Ignoring file 'OISEAUX_.H32' (Load at 15)!
WARNING: loadResource: Ignoring file 'PIC_____.H32' (Load at 16)!
WARNING: loadResource: Ignoring file 'PLONG110.H32' (Load at 17)!
WARNING: loadResource: Ignoring file 'PNEUMA05.H32' (Load at 18)!
WARNING: loadResource: Ignoring file 'PORTE2__.H32' (Load at 19)!
WARNING: loadResource: Ignoring file 'PORTE___.H32' (Load at 20)!
WARNING: loadResource: Ignoring file 'RIDEAU2_.H32' (Load at 21)!
WARNING: loadResource: Ignoring file 'RIDEAU__.H32' (Load at 22)!
WARNING: loadResource: Ignoring file 'TAXIGO__.H32' (Load at 23)!
WARNING: loadResource: Ignoring file 'TAXIVIEN.H32' (Load at 24)!
WARNING: loadResource: Ignoring file 'TELEPONE.H32' (Load at 25)!
WARNING: loadResource: Ignoring file 'TICTAC__.H32' (Load at 26)!
WARNING: loadResource: Ignoring file 'VENT2___.H32' (Load at 27)!
WARNING: loadResource: Ignoring file 'VENT____.H32' (Load at 28)!
WARNING: loadResource: Ignoring file 'ELECT375.H32' (Load at 29)!
WARNING: loadResource: Ignoring file 'GRENOUIL.H32' (Load at 30)!
WARNING: loadResource: Ignoring file 'GRILLON_.H32' (Load at 31)!
WARNING: loadResource: Ignoring file 'HIBOU___.H32' (Load at 32)!
WARNING: loadResource: Ignoring file 'STBY0105.H32' (Load at 33)!
WARNING: loadResource: Ignoring file 'COEUR___.H32' (Load at 34)!
WARNING: loadResource: Ignoring file 'TELEX___.H32' (Load at 35)!
WARNING: Unable to find part file for filename 'LOGO.PI1'!
Assertion failed: foundFileIdx >= 0 && foundFileIdx < (int32)g_cine->_partBuffer
.size(), file ../scummvm-1.3.0/engines/cine/part.cpp, line 222

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

If I can help finding the solution please contact me.

Ticket imported from: #3311143. Ticket imported from: bugs/5734.

Change History (8)

comment:1 by digitall, 8 years ago

Please note that Operation Stealth is not officially supported yet and suffers from a number of Gfx glitches, though it should be completable.

Please can you confirm your operating system?

Can't replicate on Linux x86_32 with v1.3.0 or latest Git Master using:
Operation Stealth(256 colors/DOS/English (GB))

Please can you attach a listing of your datafiles and their md5sums, so I can confirm the exact version with the issue?
e.g. using this tool on Windows: http://www.md5summer.org/
Also, if you can describe the exact version i.e. Publisher, CD/Floppy, Reference Product ID from CD-ROM etc. that may help.

comment:2 by SF/markcoolio, 8 years ago

It is Operation Stealth(256 colors/DOS/English (US)), was published by Interplay and came on floppy.

MD5 of the detection entry is:
"procs00" => "862a75d76fb7fffec30e52be9ad1c474")

The version you mention runs fine here too as I also own it. It is just the US version who fails.

comment:3 by bluegr, 8 years ago

This is odd, I just tried the US version and I get no such error with LOGO.PI1, and the game starts normally. It should be INTRO.PI1, not LOGO.PI1.

LOGO.PI1 is found in Future Wars... are you sure that you haven't somehow mixed the game files of these two games? This is the only likely cause for this error that I can think of

comment:4 by digitall, 8 years ago

markcoolio: Could you please confirm if bluegr's suggestion was or was not the cause of this issue.

comment:5 by SF/markcoolio, 8 years ago

Sorry for late reply, but was on a long business trip.
I just grabbed my floppy disks again (I indeed own Future wars too) and this time watched carefully to put them into separate directories.
Most important.. maybe i forgot to copy all files last time or indeed mixed them up. but now everything is fine!
thebluegr was right!
thx for helping

comment:6 by wjp, 8 years ago

Owner: set to bluegr
Resolution: invalid
Status: newclosed

comment:7 by digitall, 11 months ago

Component: Engine: Cine

comment:8 by digitall, 11 months ago

Game: Operation Stealth
Note: See TracTickets for help on using tickets.