Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5697 closed defect (fixed)

SCI: Castle of Dr. Brain - Crash after Final Bookcase Riddle

Reported by: SF/vorph999 Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Castle of Dr. Brain

Description

Game: Castle of Dr. Brain (VGA)
Game Version: 1.0.0 E
ScummVM Version: 1.3.0git4717-g54ddd00
OS: Windows 7 64-bit SP1

Problems: Game is (almost) completable.

Game crashes after having solved the final riddle (bookcase) as soon as dr. brain enters the room.

"Unexpected request for outgoing reference from clone at 0021:0c6e)

Savegame attached

Ticket imported from: #3299458. Ticket imported from: bugs/5697.

Attachments (1)

castlebrain.007 (54.2 KB ) - added by SF/vorph999 8 years ago.

Download all attachments as: .zip

Change History (9)

by SF/vorph999, 8 years ago

Attachment: castlebrain.007 added

comment:1 by digitall, 8 years ago

Component: Engine: SCI
Game: Castle of Dr. Brain
Summary: SCI: Castle of Dr. BrainSCI: Castle of Dr. Brain - Crash after Final Bookcase Riddle

comment:2 by digitall, 8 years ago

Thank you for your bug report.

I have tried to replicate from the attached savegame, but I am unable to load this.
This is probably because based on the VERSION.TXT on the CD, my version of Castle of Dr Brain (VGA) is 1.1

Could you attach a list of MD5sums of your datafiles to enable the exact game version with this issue to be idenitified? Thanks.
P.S. If you need a tool for this, see http://md5summer.org/

comment:3 by SF/vorph999, 8 years ago

Here you are...

406d2ec0c9cd3d8b03f320aaf1331eea *COB/RESOURCE.000
5ea6a86db51ac374d9ab24a6aa20c1f3 *COB/RESOURCE.001
74bf0a92bb3c1888e7c20a1061d96d4d *COB/RESOURCE.002
1ad2f5c5d9858451aa8896854e0cf5ae *COB/RESOURCE.003
f7cb7c8b326d9b57894c363e437f43fe *COB/RESOURCE.004
f2d5978052754f956043e8ea6ba6b3f2 *COB/RESOURCE.005
5390c9c7ecce493df68967bffd1ce9ea *COB/RESOURCE.006
497ed7b312abc0cab146d13f963b8db3 *COB/RESOURCE.007
5f9705702cb27d32314f54320f545669 *COB/RESOURCE.008
6094a42a4faab46c55c4a33bd1a430d8 *COB/RESOURCE.CFG
453daa935535cef68d19704c2b1b78a2 *COB/RESOURCE.MAP

when you need additional info, feel free to ask

comment:4 by digitall, 8 years ago

Thank you. I can confirm that my Sierra Original CD version does not match those as expected.
Could you describe your version's media i.e. The markings on CD, revision / pressing ID or similar, to speed up identifying a dev with the same version? This reference might help:
http://www.mobygames.com/game/castle-of-dr-brain/cover-art

comment:5 by bluegr, 8 years ago

Same as bug #3295849, fixed in rev 35086fe17c

comment:6 by bluegr, 8 years ago

Keywords: script added
Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:7 by wjp, 8 years ago

c01fed7159c313680e55458efb6529d332ebc8b0 has a new fix for this.

comment:8 by wjp, 8 years ago

Owner: changed from bluegr to wjp
Note: See TracTickets for help on using tickets.