Opened 8 years ago

Closed 8 years ago

Last modified 11 months ago

#5695 closed defect (fixed)

DEVTOOLS: Missing files in Visual Studio created project

Reported by: dreammaster Owned by: lordhoto
Priority: normal Component: Tools
Keywords: build Cc:
Game:

Description

The CREATE_PROJECT tool doesn't add the files in the 'IFDEF WIN32' section of backends/module.mk when creating the scummvm.vcproj file. This results in the resulting ScummVM project failing to link unless you manually put the files in backends/fs/windows/ into the project.

This problem occurs in the latest trunk code.

Ticket imported from: #3298255. Ticket imported from: bugs/5695.

Change History (3)

comment:1 by lordhoto, 8 years ago

Fixed in master with dea5aa8a2017ec9b9abc16b34683a1e37aafbe46.

I couldn't reproduce this bug in trunk though.

comment:2 by lordhoto, 8 years ago

Owner: set to lordhoto
Resolution: fixed
Status: newclosed

comment:3 by digitall, 11 months ago

Component: Tools
Note: See TracTickets for help on using tickets.