Opened 13 years ago

Closed 13 years ago

Last modified 18 months ago

#5653 closed defect (fixed)

KQ6: Game freezes when getting paper from web

Reported by: SF/envisaged0ne Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: Game: King's Quest 6

Description

When you are at the Isle Of Wonder and go to get the piece of paper with the word "LOVE" from the black widow's web, the game freezes after you've retrieved it and it flies away.

I've included a save game at the Isle Of Wonder. Just go right, then pull on the loose webbing on the black widow's web and retrieve the paper. After you've retrieved it, it will fly away after a few seconds, then the game freezes.

This is a relatively new bug because I was able to play the game all the way through in the past without any problems. It's doing it on the latest Daily Update. I'm using 32 bit Windows 7.

Ticket imported from: #3291115. Ticket imported from: bugs/5653.

Attachments (1)

kq6-cd-win.001 (39.4 KB ) - added by SF/envisaged0ne 13 years ago.

Download all attachments as: .zip

Change History (7)

by SF/envisaged0ne, 13 years ago

Attachment: kq6-cd-win.001 added

comment:1 by wjp, 13 years ago

Summary: Game freezes when getting paper from webKQ6: Game freezes when getting paper from web

comment:2 by wjp, 13 years ago

I can reproduce this

comment:3 by wjp, 13 years ago

Bisected this to:

bfef0f5a6fabdef5bb42cffd8b078d4511cf2a80 SCI: Fixed fading-related bugs #3267956 and #3041738

comment:4 by bluegr, 13 years ago

Fixed in rev 5654e12 by applying a more specific workaround

comment:5 by bluegr, 13 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:6 by sluicebox, 18 months ago

Owner: changed from bluegr to sluicebox

This turned out to be a script bug that relied on undefined values and not a sound bug. Fixed in with a script patch in: 33c6fe11317880fd61682acb12fd76da928dde02

Note: See TracTickets for help on using tickets.