Opened 9 years ago

Closed 9 years ago

#5641 closed defect (fixed)

DW2 - Unable to Save

Reported by: SF/m4sk Owned by: dreammaster
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld II

Description

Unable to save game in Discworld II on Android Platform. SCUMMVM menu items (Save/Return to Loader) are greyed out.
Trying virtual keyboard ends up with "clicking/tapping" at the spot where keyboard key appears.

Version : 1.3.0git4063-g6bd 1806

Ticket imported from: #3277422. Ticket imported from: bugs/5641.

Attachments (1)

tinsel.patch (598 bytes ) - added by dhewg 9 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 by dreammaster, 9 years ago

The Tinsel engine doesn't support saving directly through the GMM in either Discworld game - you need to use the F1 menu, or the F5 key directly. Whilst my first thought was to simply close this ticket as being invalid, or re-classifying it as a feature request, I'm not sure if there's any issue because of this when playing the game on a PDA. Presumably you can use the virtual keyboard to just select F5 and get the in-game save dialog that way.

comment:2 by SF/m4sk, 9 years ago

I know it's not supported through SCUMMVM directly. I've read a few posts regarding the matter and it should be possible to use the virtual keyboard. However it doesn't work. When trying to type on the keyboard, click on the key is registered as tap on the screen in the game, causing action (movement, etc.)

comment:3 by dhewg, 9 years ago

Some Android devices only have 2 hardware buttons. One maps EVENT_MAINMENU, the other KEYCODE_ESCAPE.
The Android port uses the native vkeybd of the OS, not backends/vkeybd/. And that doesn't have Fx keys (and for what).
So its impossible to invoke Fx, just because its not mapped anywhere.

comment:4 by SF/m4sk, 9 years ago

As mentioned in this forum thread : http://forums.scummvm.org/viewtopic.php?t=10084 it seems that in official release 1.2.1 , "!" key on virtual keyboard triggers the game menu and "%", "&" work as load/save.
However this is not the case for the dev version I installed (1.3.0git4063-g6bd 1806) to fix Beaneath the Steel Sky start-up crash problem. Maybe it's caused by the new "trackpoint" control system.

comment:5 by dhewg, 9 years ago

Grepping for KEYCODE in tinsel yields only a couple of used keys. How about we map the function keys additionally to the corresponding numeric key?
Mapping Fx keys would still be useful for the Android port, but reusing the vkeybd sounds reasonable. And maybe it solves the same issue on another port...

comment:6 by SF/m4sk, 9 years ago

Sounds good imho.

by dhewg, 9 years ago

Attachment: tinsel.patch added

comment:7 by dhewg, 9 years ago

attached a simple patch, i'll let someone from the tinsel engine team decide if this is appropriate.

fyi: my initial plan was to add a toggle for android, accessible via a port specific dialog.
but this is way nicer:
- you don't need to toggle forth and back
- this approach allows numbers to be used in savegame names without any key conflicts
- you can use '7' on builds with vkeybd now, since it doesn't conflict

comment:8 by dhewg, 9 years ago

erm, i meant: a toggle that maps the numeric keys to the function keys :)

comment:9 by dreammaster, 9 years ago

Owner: set to dreammaster

comment:10 by dreammaster, 9 years ago

I agree it seems like a reasonable solution for now. I've committed the changes into trunk.

comment:11 by dreammaster, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.