Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5607 closed defect (worksforme)

SCI: QFG1EGA: Audio stops working after a while.

Reported by: SF/alonzotg Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 1

Description

Sound will stop working in an old savegame because instruments are allocated but not recycled and are therefore exhausted, I get lots of:

Emulating SCI version Late SCI0

WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!
WARNING: ADLIB: Invalid patch 127 requested!

Ticket imported from: #3207305. Ticket imported from: bugs/5607.

Attachments (1)

qfg1.000 (24.9 KB ) - added by SF/alonzotg 9 years ago.
Save for Hero's Quest 1.001

Download all attachments as: .zip

Change History (14)

comment:1 by digitall, 9 years ago

To process your bug report appropriately, please be so kind and provide
the following information:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)

And attach the problematic savegame to this bug.

comment:2 by bluegr, 9 years ago

Summary: Audio stops working after a while.QFG1: Audio stops working after a while.

comment:3 by SF/alonzotg, 9 years ago

* ScummVM version (PLEASE test the latest SVN/Daily build)

atg@tortoise ~/source $ scummvm --version
ScummVM 1.2.1 (Jan 2 2011 21:17:50)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ RGB zLib FluidSynth

I could not pull the git version, the feed was 404.

Language is English,

I'm playing the floppy version, 1.001

Platform is Linux/gentoo. (Scummvm has a habit of exposing nasty bugs in X11/fvwm...)

I can't find any button on this webpage to attach the files... I know where scummvm hides its savegames so I should be able to do it... The issue isn't exactly the loading of saves, it is merely the savegames preserve a broken state. Simply wandering around through the game for a few hours should be enough to expose the issue.

comment:4 by digitall, 9 years ago

https://github.com/scummvm/scummvm/tarball/master should be fine to download a tar.gz of the latest source.

It is probably not critical, but since you are building from source, rather than using a pre-built daily build, please note the GCC / binutils version you are using i.e. gcc --version and ld --version.

Please attach the savegame at issue. This can be done by clicking on "Attached File" below, then clicking "Add a file". Note that this option will only appear if you are logged into SourceForge.

Thanks.

by SF/alonzotg, 9 years ago

Attachment: qfg1.000 added

Save for Hero's Quest 1.001

comment:5 by SF/alonzotg, 9 years ago

atg@tortoise ~/source $ gcc --version
gcc (Gentoo 4.5.2 p1.0, pie-0.4.5) 4.5.2

atg@tortoise ~/source $ ld --version
GNU ld (GNU Binutils) 2.21

Yeah, getting sound to work at all in the git version was a bit of a chore but my save game came right up after I got it going. =)

comment:6 by digitall, 9 years ago

I'm sorry.. Your last comment was a little unclear as to the current status of this bug.

Please confirm:
1. whether the issue you see is still occurring with the latest Git master.
2. whether this issue occurs from a new savegame produced from the latest Git master.

comment:7 by bluegr, 8 years ago

How old is this saved game? (please specify a date)
Which version of ScummVM are you using?
Does this bug still occur with newer saved games?

comment:8 by wjp, 8 years ago

Summary: QFG1: Audio stops working after a while.SCI: QFG1: Audio stops working after a while.

comment:9 by bluegr, 8 years ago

Summary: SCI: QFG1: Audio stops working after a while.SCI: QFG1EGA: Audio stops working after a while.

comment:10 by bluegr, 8 years ago

Owner: set to bluegr
Resolution: worksforme
Status: newpending

comment:11 by bluegr, 8 years ago

I'm sorry I can't reproduce this issue with the current daily build, and the information provided is not enough to figure out if there is an actual problem here.

Unless more information is provided, I'm assuming that this issue does not occur any more. Please test the latest daily build, apparently this issue doesn't occur anymore.

Marking as pending, as this can't be reproduced with the associated saved game (or with normal game play) - if you have any more information concerning this situation you encountered (with steps to reproduce it), please provide it here.

comment:12 by bluegr, 8 years ago

There has been no activity on this for over 10 months. Changing status from "Pending" to "Closed" (which should have been done automatically, but for some reason it hasn't)

comment:13 by bluegr, 8 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.