Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5601 closed defect (fixed)

LSL6: Hanging when talking to/looking at the receptionist

Reported by: SF/dhwz Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 6

Description

Right after starting a new game, if I try to talk to the receptionist the game hangs, I see the hourglass and the blocked toolbar. This happens with both english and german version. Tested with GIT nightly build from Feb 25 2011. I did a fresh install from my CD-ROM so no game file is corrupted.

Ticket imported from: #3192166. Ticket imported from: bugs/5601.

Change History (5)

comment:1 by digitall, 9 years ago

Replicated. Will run bisection.

comment:2 by digitall, 9 years ago

Bisection shows that this regression was introduced by: commit 9ad4ad1abc75e6393617ea9c5ca8fdfc2c8de6c4 Author: md5 <md5@scummvm.org> Date: Thu Feb 24 02:17:28 2011 +0200

SCI: Fixed two bugs related to music fading

- bug #3037594: "KQ5: Music not fading when brigands leave temple" - bug #3044844: "LONGBOW: Intro skips each first verse of song"

comment:3 by digitall, 9 years ago

Owner: set to bluegr

comment:4 by bluegr, 9 years ago

Partially reverted that commit. The problem in the intro of Longbow seems to be something else, then - however, the real problem is that the fading code is guesswork, so we really need to see what SSCI is doing

comment:5 by bluegr, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.