Opened 9 years ago

Closed 9 years ago

#5599 closed defect (fixed)

CRUISE: Some texts are invisible in the intro.

Reported by: SF/vakons Owned by: digitall
Priority: normal Component: Engine: Cruise
Keywords: Cc:
Game: Cruise for a Corpse

Description

In the last scene of the intro (first scenes can be skipped with mouse click), soon after the clock, text is shown in black color and therefore is not visible.

It seems that error appeared somewhere between November 8 and December 19, 2010. Stable version 1.2.0 and SVN 1.3.0 build 54131 (Nov 8, 2010) displayed text correctly, and stable version 1.2.1 and SVN 1.3.0 build 55020 (Dec 23, 2010) shows it in black, as well as today Git build.

I have included screenshots to see the difference. They are for 256-color French version, but English, Spanish, German and Italian versions works the same. I tried all languages, since they are all on the same CD.

And, by the way, starting from version 1.2.0, the copy protection is completely skipped for this game (it worked in stable v1.1.1), with or without --copy-protection switch.

Ticket imported from: #3188309. Ticket imported from: bugs/5599.

Attachments (1)

v1.2.0 vs v1.2.1.png (37.7 KB ) - added by SF/vakons 9 years ago.
black text

Download all attachments as: .zip

Change History (9)

by SF/vakons, 9 years ago

Attachment: v1.2.0 vs v1.2.1.png added

black text

comment:1 by SF/vakons, 9 years ago

Summary: Some texts are invisible in the intro.CRUISE: Some texts are invisible in the intro.

comment:2 by digitall, 9 years ago

Owner: set to digitall

comment:3 by digitall, 9 years ago

Have Replicated. Probably revealed by one of my fixes. Will bisect for the exact cause.

comment:4 by digitall, 9 years ago

This intro text regression was introduced by cb2a20cbd05bd8d137eda0adf75609186271255d ( svn-id r54405): "CRUISE: Bugfix for #3064846 - Raoul appearing in Book screen"

https://sourceforge.net/tracker/?func=detail&aid=3064846&group_id=37116&atid=418820

Will look at copy protection skipping...

comment:5 by digitall, 9 years ago

The copy protection check was accidently disabled by an errorneous commit to cruise/script.cpp in : commit f4d38ccd407f2a007050d69e4841ba7fc53cd401 Author: Florian Kagerer <athrxx@users.sourceforge.net> Date: Sat Aug 7 14:38:07 2010 +0000

"LOL: added english floppy version" svn-id: r51834

Will correct and reinstate the check.

comment:6 by digitall, 9 years ago

Copy Protection reinstated by commit 07c054d6c63bec5a9abd1b77781958f4a83969bc

comment:7 by dreammaster, 9 years ago

Since this was affected by a previous fix to resolve a bug in a single game scene, I've decided it'll be simpler to simply revise the existing fix to only apply to the one scene it's really needed for. So the intro is no longer affected by the problem, and the text shows

comment:8 by dreammaster, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.