Opened 9 years ago

Closed 9 years ago

Last modified 12 months ago

#5593 closed defect (fixed)

ANDROID: ScummVM seems to crash on resume from background

Reported by: SF/dirtyhairy Owned by: dhewg
Priority: normal Component: Port: Android
Keywords: Cc:
Game:

Description

When I receive

Ticket imported from: #3178197. Ticket imported from: bugs/5593.

Change History (10)

comment:1 by SF/dirtyhairy, 9 years ago

Summary: Android: ScummVM doesnAndroid: ScummVM seems to crash on resume from background

comment:2 by SF/dirtyhairy, 9 years ago

Sorry, seems I hit a wrong key, commiting the report before it was ready ;) What happens: if ScummVM is sent into the background (either by receiving a call or hitting home) and then resumed, the screen flickers, sound briefly restarts, and then I am sent back to the home screen. This is the current (1.2.1) version of the android port on a HTC Desire Z (Froyo). I have only tried Hand of Fate since I don't have my other games at hand, but I'll try more on the weekend. Btw, apart from this issue, the port works perfectly - thumbs up for the great work!

comment:3 by digitall, 9 years ago

Owner: set to anguslees

comment:4 by fingolfin, 9 years ago

Summary: Android: ScummVM seems to crash on resume from backgroundANDROID: ScummVM seems to crash on resume from background

comment:5 by SF/wikipedian, 9 years ago

I can confirm this, using ScummVM 1.2.1 and Monkey Island 2 on an HTC Desire (Android 2.2). ScummVM also crashes on resume when you were in the ScummVM main menu, so this is not related to the game you're playing.

comment:6 by dhewg, 9 years ago

Component: Engine: Kyra
Game: Kyrandia 2
Owner: changed from anguslees to dhewg
Resolution: fixed
Status: newclosed

comment:7 by dhewg, 9 years ago

pause/resume was implemented with 25ef065a
see http://forums.scummvm.org/viewtopic.php?p=65859

comment:8 by (none), 8 years ago

I just had this issue on version 1.4 from the Android Market. Received a call during game play, and after the call ended I was back in the SCUMM main menu with the current game state being lost.

comment:9 by SF/siliconmind, 8 years ago

Same here. Xperia X8 (android 2.1), latest ScummVM 1.4 from Android Market. When I hit the "home" button or receive a call, ScummVM is sent into background but I'm not able to bring it back. When I try to resume I hear sound but the screen is black. I have to restart the phone or kill scummvm process to be able to run ScummVM again.

comment:10 by digitall, 12 months ago

Component: Port: Android
Note: See TracTickets for help on using tickets.