Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5588 closed defect (fixed)

FOA: Wrong colors in the Amiga version

Reported by: SF/zaurak Owned by: lordhoto
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Version:ScummVM 1.3.0svn55716 (Feb 2 2011 13:23:05)
System: Windows XP
Game: Fate of Atlantis, German Amiga version

At the end of the game (after activating the godhood machine) parts of the screen color are changing (see attached screenshot from the Amiga version). Using ScummVM the whole screen changes the color instead of parts of the screen only (see attached screenshot from ScummVM). Also attached is a savegame. To reproduce the bug, load the savegame and wait a few seconds for the color change.

Ticket imported from: #3174197. Ticket imported from: bugs/5588.

Attachments (4)

atlantisa.s12 (25.0 KB ) - added by SF/zaurak 9 years ago.
FOA Savegame
Indy_Atlantis-Amiga.png (18.9 KB ) - added by SF/zaurak 9 years ago.
FOA Screenshot (Amiga)
Indy_Atlantis-ScummVM.png (62.3 KB ) - added by SF/zaurak 9 years ago.
FOA Screenshot (ScummVM)
Indy_Atlantis-ScummVM_correct.png (58.6 KB ) - added by SF/zaurak 9 years ago.
FOA Screenshot (ScummVM) correct colors

Download all attachments as: .zip

Change History (11)

by SF/zaurak, 9 years ago

Attachment: atlantisa.s12 added

FOA Savegame

by SF/zaurak, 9 years ago

Attachment: Indy_Atlantis-Amiga.png added

FOA Screenshot (Amiga)

by SF/zaurak, 9 years ago

Attachment: Indy_Atlantis-ScummVM.png added

FOA Screenshot (ScummVM)

comment:1 by SF/zaurak, 9 years ago

I did a few tests with older ScummVM versions. The bug was already present with ScummVM 1.0.0 and 0.10.0.

by SF/zaurak, 9 years ago

FOA Screenshot (ScummVM) correct colors

comment:2 by SF/zaurak, 9 years ago

The incorrect colors change to the correct ones a bit later. After a few dialogs, Kerner activates the "Goodhood" machine. At this point the colors change to the correct ones (screenshot). However, the colors are still incorrect until this point (including the lower area).

comment:3 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:4 by sev-, 9 years ago

Priority: normalhigh

comment:5 by lordhoto, 8 years ago

It seems the problem is in script-171. It does a "palManipulate(46,32,65,20)", when I ignore this one in the ScummVM code it looks fine and all what happens is that the lava animation starts. So I guess there is some problem with that opcode. Shortly after that palManipulate call there is a set of "setRGBRoomIntensity(255,Local[9],Local[9],192,47)" calls in a loop, which also look odd since the start color (which is 192) is above the end colod (which is 47). We seem to ignore that case though.

comment:6 by lordhoto, 8 years ago

Fixed with bc6ed998a9d80b60057e910cc983a5fca7c0a002.

The fix will be included in the next nightly ScummVM development build. Thank you for reporting it.

comment:7 by lordhoto, 8 years ago

Owner: set to lordhoto
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.