Opened 9 years ago

Closed 9 years ago

Last modified 12 months ago

#5574 closed defect (invalid)

Win32: Fullscreen Tablet Pen Input

Reported by: SF/smelltastic Owned by: sev-
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

When using a Windows tablet PC running ScummVM in fullscreen, the cursor is interpreted with relative instead of absolute co-ordinates. This can be demonstrated in the GUI by running ScummVM fullscreen on a tablet and pointing the pen to the middle of the screen; as you move the pen slightly, the cursor will move in the direction away from center.

The issue is actually with SDL, but in searching around I found what may be a potential solution, used for a different SDL product:
http://code.google.com/p/grafx2/issues/detail?id=317
which links to
http://code.google.com/p/grafx2/source/detail?r=1553

I don't know if this could be implemented in ScummVM, or if it's better to wait and hope for an SDL fix.

Ticket imported from: #3155657. Ticket imported from: bugs/5574.

Change History (7)

comment:1 by SF/smelltastic, 9 years ago

Addendum: I did try this with the latest SVN, and the last couple releases, and going by some forum posts it looks like this has been a problem for around 5 years.

comment:2 by SF/iaros, 9 years ago

As a comment:

SDL_MOUSE_RELATIVE env variable set to 0 would solve your issue on linux platform (at least on my tablet it does), but maybe due to described below this environment setting would not work in Windows (at least setting the var in system variables did not work for me when I had Windows).

From http://sdl.beuc.net/sdl.wiki/SDL_envvars:

Windows version strangeness
Don't know if this is common to all platforms but apparently on Windows these routines (getenv, putenv) operate on an internal environment maintained by SDL - not based on the windows environment vars. Question related to this came up on #SDL (irc.freenode.net) about SDL_VIDEO_CENTERED appearing not to work. I confirmed that it does work but you have to set it before creating your window using putenv. (I set it before SDL_Init in my test.) That worked on WinXP Pro.
-- cid 2005-01-09 01:22:50

comment:3 by lordhoto, 9 years ago

I think this is clearly a SDL bug, thus you should rather report it to them and make them fix it.

We only use the data they describe as absolute mouse coordinates in their documentation:
http://www.libsdl.org/cgi/docwiki.cgi/SDL_MouseMotionEvent
http://www.libsdl.org/cgi/docwiki.cgi/SDL_MouseButtonEvent

I think we had similar reports like this in the past and our official stance was always to report it to the SDL people instead.

comment:4 by lordhoto, 9 years ago

Summary: Win32 Fullscreen Tablet Pen InputWin32: Fullscreen Tablet Pen Input

comment:5 by sev-, 9 years ago

Yes, it is an SDL bug and we cannot even detect that you're running tablet version, i.e. we abstract from the hardware with SDL.

Closing.

comment:6 by sev-, 9 years ago

Owner: set to sev-
Resolution: invalid
Status: newclosed

comment:7 by digitall, 12 months ago

Component: Port: Win32
Note: See TracTickets for help on using tickets.