Opened 17 years ago

Closed 17 years ago

Last modified 8 months ago

#557 closed defect (fixed)

ALL: Save game fails silently

Reported by: SF/vesa_karvonen Owned by: fingolfin
Priority: normal Component: --Other--
Keywords: Cc:
Game:

Description

ScummVM 0.2.7 CVS
Built on Oct 28 2002 21:16:25

An attempt to save a game fails silently if the
directory where the game files reside is not writable.
The user is given no hint whatsoever to the cause of
the failure.

To reproduce the problem, just chmod the directory to
non-writable and attempt to save a game.

Ticket imported from: #636141. Ticket imported from: bugs/557.

Change History (6)

comment:1 Changed 17 years ago by fingolfin

We could just display an error dialog in the case of a write
faillure I guess.

comment:2 Changed 17 years ago by fingolfin

Summary: Save game fails silentlyALL: Save game fails silently

comment:3 Changed 17 years ago by fingolfin

Owner: set to fingolfin

comment:4 Changed 17 years ago by fingolfin

We now display an error dialog if save or load fails

comment:5 Changed 17 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:6 Changed 8 months ago by digitall

Component: --Unset----Other--
Note: See TracTickets for help on using tickets.